incorrect autocomplete with t or p prefix url, then tab, and appending onto url

RESOLVED DUPLICATE of bug 202992

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 202992
12 years ago
12 years ago

People

(Reporter: drachma, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

For any websites that are stored in location bar history--
When deciding to visit that url using autocomplete + TAB, if the stored url begins with a 't' or 'p', upon hitting Tab, autocomplete truncates http:// and results in an incomplete url if you append onto the url.

Result is: "Firefox doesn't know how to open this address"

URL in location bar: "ttp://thomas.com/new", or "p://partypoker.com/login"

Note: This only happens when you append onto the stored url.

Reproducible: Always

Steps to Reproduce:
1. Visit a website that starts with 't' or 'p', i.e. http://partypoker.com
2. Navigate to location bar and type only 't' or 'p'
3. Press tab to highlight URL
4. Add on to the end of the URL with any string, i.e. /login
5. URL in location bar shows as p://partypoker.com/login
6. Press enter
Actual Results:  
Message: "Firefox doesn't know how to open this address, because the protocol (ttp or p) isn't associated with any program."

Expected Results:  
Autocompletes the prefix http://
so we should get http://partypoker.com/login

This only happens when you append onto the stored url.

Seems to only happen if it's a character within the prefix "http://" which is automatically appended by Firefox when you hit tab.

*** This bug has been marked as a duplicate of 202992 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.