The deadline field could benefit from a date picker widget

RESOLVED FIXED in Bugzilla 4.0

Status

()

Bugzilla
Creating/Changing Bugs
P1
enhancement
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: Douglas Calvert, Assigned: Max Kanat-Alexander)

Tracking

(Blocks: 1 bug, {ue})

unspecified
Bugzilla 4.0
Bug Flags:
approval +

Details

(URL)

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

12 years ago
The deadline field would be a lot easier to use if there was a date picker widget. These date pickers are popping up all over the web. This is not exactly a AJAX issue but it would be easier to solve with whatever js framework is included for the AJAXification. For an example date picker widget take a look at:

http://www.frequency-decoder.com/demo/fd-date-picker/

Comment 1

12 years ago
I've done this using Jason Moon's javascript date picker:
http://mburke.blogspot.com/2006/05/bugzilla-and-jasons-date-input.html

Only tested on Windows with IE6 and FF. 

He hasn't replied to me so I don't know his license beyond the fact that any use with attribution is allowed.  But I modified the script . . .

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

9 years ago
This would be very easy to do now that we have a date-picker widget for date/time fields.

pyrzak's students' research indicated that the lack of this date-picker was a problem. (Largely because it's inconsistent with any date/time custom field that appears on enter_bug.cgi.)
Keywords: ue
Priority: -- → P1
(Assignee)

Updated

9 years ago
Blocks: 490786

Comment 3

9 years ago
Created attachment 410459 [details]
hack to display calendar button next to the deadline

This is a hack for 3.4.2.
You can use it in custom templates to add the calendar button next to "deadline".
Thanks for a great piece of software!

Comment 4

9 years ago
Created attachment 411765 [details] [diff] [review]
Tip

I love it when I go to submit a patch and someone has already done so. :D

This patch is against tip. I have tested this on tip as well.
Assignee: create-and-change → ghendricks
Attachment #410459 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #411765 - Flags: review?(LpSolit)

Comment 5

9 years ago
Frank, next time be sure to request review and upload a diff file (patch). It makes it a lot easier for the devs to apply and test. ;)

Comment 6

9 years ago
Created attachment 411776 [details] [diff] [review]
Tip - V2

We should have it on bug entry and update-multiple as well.
Attachment #411765 - Attachment is obsolete: true
Attachment #411776 - Flags: review?(LpSolit)
Attachment #411765 - Flags: review?(LpSolit)

Comment 7

9 years ago
Duplicating code is not good. We should put it in a shared template (there is one already, probably), and PROCESS it.

Comment 8

9 years ago
Created attachment 411784 [details] [diff] [review]
Tip - V3

Moved processing to a block in bug/time.html.tmpl
Attachment #411776 - Attachment is obsolete: true
Attachment #411784 - Flags: review?(LpSolit)
Attachment #411776 - Flags: review?(LpSolit)

Comment 9

9 years ago
Sorry for using the incorrect procedure. I'll try to remember this next time...
Cheers
(Assignee)

Comment 10

9 years ago
Comment on attachment 411784 [details] [diff] [review]
Tip - V3

Why don't you just use bug/field.html.tmpl and fake the type or something?
(Assignee)

Comment 11

9 years ago
Yeah, in fact, just set the "type" of the deadline field in the database and then just use bug/field.html.tmpl along with bug_fields.deadline.

Comment 12

9 years ago
But deadline is a Date type, not a datetime. To my knowledge it is the only one of this type. Why go through all the trouble of defining a new type?
(Assignee)

Comment 13

9 years ago
(In reply to comment #12)
> But deadline is a Date type, not a datetime. To my knowledge it is the only one
> of this type. Why go through all the trouble of defining a new type?

  It doesn't need a new type. The DATETIME type will work just fine for it.
(Assignee)

Updated

9 years ago
Attachment #411784 - Flags: review?(LpSolit) → review-
(Assignee)

Comment 14

9 years ago
Comment on attachment 411784 [details] [diff] [review]
Tip - V3

r- based on last few comments.

Updated

8 years ago
Duplicate of this bug: 536511
(Assignee)

Comment 16

8 years ago
Created attachment 425727 [details] [diff] [review]
v4

Here we go! Pretty straightforward.
Assignee: ghendricks → mkanat
Attachment #411784 - Attachment is obsolete: true
Attachment #425727 - Flags: review?(LpSolit)

Comment 17

8 years ago
Comment on attachment 425727 [details] [diff] [review]
v4

OK, I see what you meant now. This looks good.
Attachment #425727 - Flags: review?(LpSolit) → review+

Updated

8 years ago
Flags: approval?
Target Milestone: --- → Bugzilla 3.8
(Assignee)

Updated

8 years ago
Flags: approval? → approval+
(Assignee)

Comment 18

8 years ago
Thanks for the review, ghendricks! :-)

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/                       
modified Bugzilla/Bug.pm
modified Bugzilla/Field.pm
modified skins/standard/show_bug.css
modified template/en/default/bug/edit.html.tmpl
modified template/en/default/bug/create/create.html.tmpl
modified template/en/default/list/edit-multiple.html.tmpl
Committed revision 6999.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Keywords: relnote
(Assignee)

Comment 19

8 years ago
Added to the release notes in bug 604256.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.