italic text renders illegibly on MacOS X

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: cmason, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

The <em> tag renders poorly on Firefox 1.5.0.1 on MacOS X (10.4.5).  The font is poor and text is clipped.  It almost appears as if the text is being italicized twice.  This doesn't occur on Windows XP.

Reproducible: Always

Steps to Reproduce:
See attached HTML fragment.
Actual Results:  
See attached mac1.0.5.1.png.

Expected Results:  
See attached win1.0.5.01.png.
(Reporter)

Comment 1

13 years ago
Created attachment 214357 [details]
HTML fragment containing <em> tag and sans-serif font.
(Reporter)

Comment 2

13 years ago
Created attachment 214358 [details]
Screenshot of <em> tag and sans-serif font rendered incorrectly on Mac.
(Reporter)

Comment 3

13 years ago
Created attachment 214359 [details]
Screenshot of <em> tag and sans-serif font rendered correctly on Windows.
(Reporter)

Comment 4

13 years ago
Note that sans-serif font is also necessary for this to be reproduced.  Serif font does not show this bug.

Comment 5

13 years ago
WFM with the testcase in comment 1 and the w3.org URL.  I'm using today's Firefox trunk build on Mac OS X 10.4.5 on a PowerBook.
Summary: <em> tag renders illegibly on MacOS X → <em> tag (italic text?) renders illegibly on MacOS X
(Reporter)

Comment 6

13 years ago
Created attachment 214389 [details]
Screenshot of <em> tag and sans-serif font rendered incorrectly on Mac build 20060307.
Attachment #214358 - Attachment is obsolete: true
(Reporter)

Comment 7

13 years ago
Note that <i> shows the same behavior.  Changing subject to reflect this.  This is with trunk build 20060307.
Summary: <em> tag (italic text?) renders illegibly on MacOS X → italic text renders illegibly on MacOS X
(Reporter)

Comment 8

13 years ago
Further digging shows this to be a problem with two postscript fonts (Courier and Helvetica) that were installed on my system.  Oddly, the fonts themselves are fine; there must have been some caching happening somewhere because after removing and reinstalling them, they render fine.  Not sure why only Firefox was tickling this and why only at certain sizes.  I doubt anyone else will have this problem, so I'm going to close the bug.  Frustrating waste of time...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.