Add symbols to nightly builds

RESOLVED DUPLICATE of bug 367775

Status

--
enhancement
RESOLVED DUPLICATE of bug 367775
13 years ago
16 days ago

People

(Reporter: bc, Unassigned)

Tracking

Trunk
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Not having symbols in nightly builds makes it difficult to debug hard to reproduce crashes or to verify if a particular crash in a nightly build has been fixed. I suggest we add MOZ_DEBUG_SYMBOLS to the trunk permanently and to branch nightly builds during the period prior to beta so that useful stacks can be captured.

Comment 1

13 years ago
um, i thought talkback worked by getting symbols
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> um, i thought talkback worked by getting symbols
> 

as far as I know, talkback associates addresses with the symbols that are uploaded to the talkback servers. I am talking about building and distributing the nightly builds so that when you attach a debugger to a crash you get a stack with the function names and line numbers.

Comment 3

13 years ago
those are the same symbols, and this is a duplicate.
Whiteboard: DUPEME
(Reporter)

Comment 4

13 years ago
You thinking of bug 320490?

Comment 5

11 years ago
Bug 320490 only applies to windows systems, not Linux. A solution for Linux systems is still needed.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 367775

Updated

5 years ago
Whiteboard: DUPEME
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.