Right click causes instant crash if navigation was stopped

RESOLVED FIXED

Status

()

Core
Document Navigation
--
critical
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Dorian, Assigned: Dorian)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.18 KB, patch
timeless
: review+
Details | Diff | Splinter Review
(Assignee)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060115 K-Meleon/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060115 K-Meleon/1.0

This is reproducible with mfcembed

Reproducible: Always

Steps to Reproduce:
1. Open a webpage
2. Stop navigation. The view must stay entirely white.
3. Right click

Actual Results:  
Crash
(Assignee)

Comment 1

12 years ago
Created attachment 214405 [details] [diff] [review]
patch
(Assignee)

Updated

12 years ago
Attachment #214405 - Flags: review?

Comment 2

12 years ago
Comment on attachment 214405 [details] [diff] [review]
patch

in the future, please use cvs diff -pU10
where 10 is a number big enough to show why your patch is useful. i used bugzilla's diff viewer and asked for 30 lines of context to see why this was right.

i'm not sure if we like NS_ENSURE_ARG or NS_ENSURE_ARG_POINTER, there's a bug about deciding which to use when since it's not actually documented. personally i lean toward the latter.
Attachment #214405 - Flags: superreview?(bzbarsky)
Attachment #214405 - Flags: review?
Attachment #214405 - Flags: review+
Comment on attachment 214405 [details] [diff] [review]
patch

Makes sense.
Attachment #214405 - Flags: superreview?(bzbarsky) → superreview+

Updated

12 years ago
Assignee: adamlock → boissomag
Status: UNCONFIRMED → NEW
Ever confirmed: true
who passed null here and why? and why is this not a bug in the caller? 

Comment 5

12 years ago
erm, and normally one should provide a stack trace for bugs like this.

biesi's right, the patch is wrong, the method's not an exported method so someone else shouldn't have passed that in to it. i know there was some reason i liked the patch, but this time my sleepy self can't find it.
(Assignee)

Comment 6

12 years ago
Created attachment 217448 [details] [diff] [review]
patch2

Nah, it's just my bad for not having provided an explanation.
I suppose this one is better.
Attachment #214405 - Attachment is obsolete: true

Updated

12 years ago
Attachment #217448 - Flags: superreview?(bzbarsky)
Attachment #217448 - Flags: review+
Attachment #217448 - Flags: superreview?(bzbarsky) → superreview+
Flags: blocking1.9a2?
Checked in.  Dorian, in the future please mail someone if reviewed patches are not getting checked in?  We lose track of bugs at times, esp. if not subscribed to the bug.  ;)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking1.9a2?
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.