No confirmation dialog after clicking Clear History

RESOLVED FIXED in Firefox 2 alpha2

Status

()

Firefox
Bookmarks & History
P2
normal
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Assigned: Joe Hughes)

Tracking

({fixed1.8.1})

Trunk
Firefox 2 alpha2
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Steps to reproduce:
1. Menu History -> Clear History.
2. Everything in History disappears instantly, which is dangerous for I clicked it only by accident; meant to click View All History.

Comment 1

12 years ago
Confirmed on Firefox 2 branch (Mac OS). It's annoying because the menu item uses an ellipsis (Clear All History...), which indicates that a confirmation dialog is to be expected.
(Assignee)

Comment 2

12 years ago
Created attachment 216242 [details] [diff] [review]
Gets rid of "Clear History..." menu item, moves "Clear Private Data..." menu item from Tools menu to take its place
Assignee: nobody → joe
Status: NEW → ASSIGNED
Attachment #216242 - Flags: ui-review?(beltzner)
Attachment #216242 - Flags: superreview?(bugs)
Attachment #216242 - Flags: review?(annie.sullivan)
(Assignee)

Updated

12 years ago
OS: Windows XP → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → Firefox 2 alpha2

Comment 3

12 years ago
Comment on attachment 216242 [details] [diff] [review]
Gets rid of "Clear History..." menu item, moves "Clear Private Data..." menu item from Tools menu to take its place

>-                <menuseparator id="startTabHistorySeparator"/>
>-                <menuseparator hidden="true" id="endTabHistorySeparator"/>
>-                <menuitem label="&historyClearCmd.label;"
>-                          command="Browser:ClearHistory"/>
>+                <menuseparator hidden="true" id="startTabHistorySeparator"/>
>+                <menuseparator id="sanitizeSeparator"/>
>+                <menuitem id="sanitizeItem" 
>+                          accesskey="&clearPrivateDataCmd.accesskey;"
>+                          label="&clearPrivateDataCmd.label;"
>+                          key="key_sanitize" command="Tools:Sanitize"/>

HistoryMenu.update() still references endTabHistorySeparator.  Please fix this, and make sure that the separators show correctly above and below the tab history when there is history, and only one separator shows when there is no tab history.
Attachment #216242 - Flags: review?(annie.sullivan) → review-
(Assignee)

Comment 4

12 years ago
Created attachment 216270 [details] [diff] [review]
update to address Annie's comment

Right, thanks.
Attachment #216242 - Attachment is obsolete: true
Attachment #216270 - Flags: ui-review?(beltzner)
Attachment #216270 - Flags: superreview?(bugs)
Attachment #216270 - Flags: review?(annie.sullivan)
Attachment #216242 - Flags: ui-review?(beltzner)
Attachment #216242 - Flags: superreview?(bugs)

Updated

12 years ago
Attachment #216270 - Flags: review?(annie.sullivan) → review+
Comment on attachment 216270 [details] [diff] [review]
update to address Annie's comment

ui-review=me (beltzner's about a 1 in 4 chance to get to this soon)

note: brett filed a dupe for this late this week
Attachment #216270 - Flags: ui-review?(beltzner) → ui-review+
*** Bug 331493 has been marked as a duplicate of this bug. ***
Comment on attachment 216270 [details] [diff] [review]
update to address Annie's comment

sr=ben@mozilla.org
Attachment #216270 - Flags: superreview?(bugs) → superreview+
(Assignee)

Comment 8

12 years ago
Landed on branch & trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Updated

12 years ago
Blocks: 331829

Comment 9

12 years ago
Ughh!  I've always hidden the "Go" menu item (which has now become "History") via userChrome.css because it has never provided any value to me at all.  Now that "Clear Private Data" has been moved to "History" this is a pain.  Can we not get it back to Tools, since it performs the role of a tool?  Yes, I know I can "Ctrl+Shift+Del" to perform the same function.  I don't want to do that nor do I want to have "History" enabled just to be able to "Clear Private Data", it simply takes up valuable space on my menu bar and none of what I've seen as part of places provide any value to me in the "History" menu item.

Bryan

Comment 10

12 years ago
I don't think it will be moved back to tools. The point of the changes to the history menu are to make it useful (this goes beyond just "clear history". You're asking to make it useless so you can disable it, which is exactly opposite of the goal.

Comment 11

12 years ago
Are there any hacks you're aware of that I can use in userChrome.css to "move" it back to tools?  As it stands now I have to keep that menu item enabled just to use that function (remember, I don't want to have to manually do it via keyboard cmds) and having it enabled throws off the icons i've added to the right of Help.  Arghhh

I would think you'd have to add alot more low hanging fruit in order to make the History menu item truly useful IMO.  

Bryan

Comment 12

12 years ago
(In reply to comment #11)
> Are there any hacks you're aware of that I can use in userChrome.css to "move"
> it back to tools?

Not CSS. You can write an extension.
Moving sanitizeItem into a MOZ_PLACES ifdef causes javascript errors starting the browser when places is not enabled (which we need at least for performance testing).
Depends on: 333930

Updated

12 years ago
No longer blocks: 331829
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.