statefarm.com - The bill-pay function does not work. Each time I click through a step, FireFox freezes. It does NOT shut the program down, however. It just stops loading.

RESOLVED DUPLICATE of bug 336417

Status

RESOLVED DUPLICATE of bug 336417
13 years ago
3 years ago

People

(Reporter: susannah, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When I access my insurance policy on www.statefarm.com to pay my monthly insurance bill, there are 3 steps to go through to complete the bill-paying service. Each time I enter the information required on each page (the amount I want to pay, the account I want the money withdrawn from, etc.), and click the "Continue" button, Firefox freezes. It does not shut the program down, it simply stops loading or performing the function the "Continue" button is supposed to perform. I end up using IE to access that site and pay my bill each month.

Reproducible: Always

Steps to Reproduce:
1. Log into account
2. Attempt to pay bill online
3. Click "Continue"
4. I can provide access to my account in order to demonstrate this problem, if need be.

Actual Results:  
FireFox stops loading. It does not crash or shut down; it simply stops loading as if it's finished loading or performing the function I'm trying to perform.

Expected Results:  
It should have continued to another screen to confirm my payment.

This problem did not always occur; I paid my bill online for over a year successfully using FireFox. The first time I encountered the problem was in December 2005. I try every month to pay my bill online using FireFox, but always end up using IE to pay it. FireFox successful allows me to pay all my other bills online. To my knowledge, the State Farm web site has not changed.

Comment 1

13 years ago
Susannah, did you first see the problem when you upgraded to Firefox 1.5? I assume Firefox 1.0 worked fine.

If you wouldn't mind helping us diagnose this it would be great.

We have an update to Firefox 1.5.0.2 coming out relatively soon. Would you mind uninstalling the 1.5.0.1 version you have now and installing the new version from <http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8.0/> to see if it is an issue that has been fixed in the new version  ?

If Firefox 1.5.0.2 still has problems, we have an update to Firefox 1.0.8 coming out soon as well. You can get the builds from <http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-aviary1.0.1/>.

Thanks!

Updated

13 years ago
Summary: The bill-pay function on State Farm's web site does not work. Each time I click through a step, FireFox freezes. It does NOT shut the program down, however. It just stops loading. → statefarm.com - The bill-pay function does not work. Each time I click through a step, FireFox freezes. It does NOT shut the program down, however. It just stops loading.

Comment 2

12 years ago
Having just made my payment, I can confirm this for:
FF 1.5.0.4 on MacOS X 10.4.6
FF 1.5.0.4 on WinXP
and even Camino 1.0 but I remember this happening with FF 1.0.x too.
The site's using ASP pages.

A step-through: I log in, choose "Pay Online," next screen is Insurance Type with a checkbox. I check the box and click the "Start Pay Process." The button goes gray and no other action occurs. HOWEVER, I can uncheck the box and recheck it the button becomes active again. I click it the app continues.
The next two pages involve radio buttons and then a combo box each with a Continue button without issue.
Finally, the last page that asks to confirm payment via username and password. I enter both and choose "Confirm." Button goes gray again and I'm stuck. No checkbox to uncheck and recheck to like the previous. Game over, log off, onto IE.

Comment 3

12 years ago
cj, can you please clear your javascript console, then perform the same steps, then paste the error messages (if any) here?

Comment 4

12 years ago
Created attachment 225030 [details]
Errors generated stepping through the State Farm online payment.

Could not do the final button. As much I love the FF, I don't want pay my insurance twice. ;)

However, I did encount the other incident where I can uncheck and recheck a box to have the button activate.

Comment 5

11 years ago
Reporter, is this still a problem? See bug 336417

Comment 6

10 years ago
I strongly suspect this is a dupe of bug 336417.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 336417
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.