Closed Bug 32993 Opened 20 years ago Closed 20 years ago

mozilla crashes after resize of windows start bar

Categories

(SeaMonkey :: General, defect, P3)

x86
Windows 95
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: dwlee2, Assigned: cbegle)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win95; U)
BuildID:    2000030317

when i accidentally resized my windows start bar, mozilla stopped responding 
completely.  it froze my windows as well (ctrl-alt-del showed that explorer was 
not responding).  i couldn't restore the size of my start bar as explorer was 
non-responsive, but only after i closed mozilla did explorer come back

Reproducible: Always
Steps to Reproduce:
1. launch mozilla
2. with the start bar visible and in "always on top" mode, resize the windows 
start bar 
3. windows explorer (desktop) now freezes; desktop icons are no longer visible 
and the start bar can't be resized again

Actual Results:  after i resized the start bar, the resize cursor (north-south 
direction) remained visible.  i could not resize the start bar, i could not use 
the Windows keyboard key to open the start menu.  it's not until i closed 
mozilla did explorer start responding again

Expected Results:  previous versions of Netscape have the browser refresh the 
contents of the screen to accommodate the new space afforded to it.  mozilla 
just freezes Windows explorer (not completely, as i could shut down mozilla)

start bar must be in "always on top" mode
*** Bug 32994 has been marked as a duplicate of this bug. ***
dwlee2@julian.uwo.ca - I can't reproduce this either on M14 (the day before the 
build you are using, or on 2000032109, a build from two days ago. Could you 
please download a current build and see if you can reproduce this behaviour?

Gerv
Also unable to reproduce with 32210 build under NT.  Markign WORKSFORME.
Reporter, if you still see this in a current build please reopen.
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Using 2000032210 build, I was able to reproduce this bug.  On resizing the start 
bar, Explorer was not responding.  Minimizing all windows shows no desktop 
icons.  Cannot resize start bar again.  Closing mozilla, Explorer returned.

As well, I can't reopen the bug (I don't have permissions even though I opened 
this bug log *shrugs)
I should also mention that this bug happens for me when mozilla is maximized to 
fill the screen area (less the start bar, of course)
Reopen for further investigation
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
dwlee2@julian.uwo.ca - could you completely remove all traces of your Mozilla 
installation (including C:\Windows\moz*.dat) and reinstall a new nightly. If you 
still see this problem I'd be surprised, as I know of no other Win95 user who 
has problems with start bar resizing (including me...) :-)

Gerv
Well, I've gotten the 26 Mar 2000 nightly build now, and so far I haven't seen 
the bug recur, but mind you, I can't always reproduce-on-demand.  It seems to 
happen whenever I'm loading one site or another, and even then if I load the 
same site and try to reproduce the resize "bug," it doesn't always happen.  
Might have to do with all the other "tinkering" I've done with my computer every 
now and then.  *shrugs*
dwlee2@julian.uwo.ca I'm gonna mark this WORKSFORME.  Please re-open it with
details if you see this behavior again.  Thanks for the report and followup.
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
tested on 3-31-00 build win95
marked as verifed
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.