bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Re-show the alert notification when clicking on the biff icon in the system tray

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
General
RESOLVED FIXED
13 years ago
6 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

({fixed1.8.1})

Trunk
Thunderbird2.0
x86
Windows XP
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

13 years ago
When the biff icon is visible in the system tray, it would be neat if the user could left click the icon and have us pop the alert notification back up (maybe we don't animate it at all).

We could then add a little close button in the upper right corner that would let you close the alert.

Comment 1

13 years ago
(In reply to comment #0)
> We could then add a little close button in the upper right corner that would
> let you close the alert.

Related to bug 273951?
(Assignee)

Comment 2

13 years ago
Created attachment 214955 [details]
screen shot with a close button lined up in the upper right hand corner

I'm trying several ideas for the close button. This one seems to look the best so far. Upper right corner, not vertically centered with the alert title text. I like this layout a lot when the dialog is wide (like the 2nd image in the picture). Not so much when the window is not as wide (like the first image).

I've also tried but didn't really like:

1) Using the black X from http://lxr.mozilla.org/mozilla/source/toolkit/themes/qute/global/icons/Close.gif

2) using the red close button but lining it up so it's on the same line as the alert title (but all the way on the right of course).

Comment 3

13 years ago
I like the orange+white x, like ff's tab close widget. I don't think the narrow case is that common, because usually subjects will be a bit longer, but could you do something like add padding to the title, e.g., a few spaces at the beginning and end?
(Assignee)

Comment 4

13 years ago
Created attachment 214965 [details] [diff] [review]
the fix

I want to look at this a little more before I request a review, but here's the patch that implements this feature.

Single left click re-shows the alert without animation. Double click still opens up the 3 pane window.
(Assignee)

Comment 5

13 years ago
Comment on attachment 214965 [details] [diff] [review]
the fix

1) add an argument when opening the alert for animating on open so we can distinguish the case where we want to open it right away and leave it open vs. the usual animation case.

2) showAlert needs to handle both the normal animation case and the case where we want to open it immediately.

3) renamed animateAlert to animateOpen and closeAlert to animateClose

4) add a generic closeAlert method separate from animateClose which calls back to the listener and then closes the window

5) lays a close button ontop of the window in the upper right hand corner using a stack.

6)some timer magic to determine if a left click is a single click or a double click. In the case of a single click, call the new method, ShowNewAlertNotification

7) ShowAlertMessage is now a seamonkey only method instead of having the thunderbird ifdefs inside of it. Thunderbird now uses ShowNewAlertNotification. The code in this method isn't new, just moved from an ifdef in the old routine. 

8) Pass in the animation flag to the alert window as a window argument.

9)
Attachment #214965 - Flags: superreview?(bienvenu)

Updated

13 years ago
Attachment #214965 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Updated

13 years ago
Blocks: 312940
(Assignee)

Comment 6

13 years ago
on the branch and trunk
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Comment 7

13 years ago
It would be nice if this feature would work even when the "Show an alert" preference is turned off.
(Assignee)

Comment 8

13 years ago
(In reply to comment #7)
> It would be nice if this feature would work even when the "Show an alert"
> preference is turned off.
> 

that should be trivial to add, file a bug and i'll do it :)

Comment 9

13 years ago
one issue is that for performance/bandwidth reasons, some imap users might want to turn this off completely. So if turning that pref off makes us not fetch the message bodies, clicking the alert might not do anything useful.

Updated

6 years ago
Duplicate of this bug: 273951
You need to log in before you can comment on or make changes to this bug.