Make places handle HTTP 302 "redirects"

RESOLVED DUPLICATE of bug 737836

Status

()

Firefox
Bookmarks & History
P5
normal
RESOLVED DUPLICATE of bug 737836
12 years ago
10 months ago

People

(Reporter: Brett Wilson, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
 
(Reporter)

Comment 1

12 years ago
For clarification, when you encounter this type of redirect you get two entries in your history, where it would be desirable to only get one. They also seem to get added in the wrong order, so at least we should make it so the visit times are always in the right order. The problem now may be that the two visits are added faster than the resolution of our clock, and they have the same add time which messes up sorting.
Priority: -- → P4
Target Milestone: --- → Firefox 2 beta1
(Reporter)

Updated

12 years ago
Priority: P4 → P5
Target Milestone: Firefox 2 beta1 → Firefox 3
(Reporter)

Updated

12 years ago
Assignee: brettw → nobody
Target Milestone: Firefox 3 → ---
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Comment 3

6 years ago
Any suggestions on where to start looking at this?
well, we should check first where we are, are the visits still added in reverse order? Are both of them shown in the history menu? What about the locationbar?
Then the starting point for the visit is the docshell, that calls into History.cpp.

Updated

2 years ago
Priority: P5 → --

Updated

2 years ago
Priority: -- → P4
Priority: P4 → P5
I'm not quite sure, but this feels like bug 737836.
Depends on: 737836

Comment 6

10 months ago
(In reply to Mark Banner (:standard8) from comment #5)
> I'm not quite sure, but this feels like bug 737836.

Part of it, the other part has been fixed when we changed history.cpp implementation.
I don't think there's further interesting work to do here.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
No longer depends on: 737836
Resolution: --- → DUPLICATE
Duplicate of bug: 737836
You need to log in before you can comment on or make changes to this bug.