Bookmark folders with the same name merged after import

VERIFIED FIXED in Firefox 3 alpha8

Status

()

Firefox
Bookmarks & History
P5
normal
VERIFIED FIXED
12 years ago
8 years ago

People

(Reporter: Adam Kowalczyk, Unassigned)

Tracking

Trunk
Firefox 3 alpha8
Points:
---
Bug Flags:
blocking-firefox3 +
in-testsuite ?
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060309 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060309 Firefox/1.5

If there are two or more folders with the same name (in the same place in the hierarchy) they get merged when importing to a Places-enabled build. I.e. import results in only one folder containing the items from all the old folders.

Reproducible: Always

Steps to Reproduce:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060309 Firefox/1.6a1
Yep, I see the same. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
This is the design. Why do you have two folders with the same name in the same parent?

We were going to be referencing folders with "path"-style names in several places, which is why it works this way. With the UI redesign, I'm not sure whether this will be necessary or not.
OS: Windows XP → All
Priority: -- → P5
Target Milestone: --- → Firefox 2 beta1
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> This is the design. Why do you have two folders with the same name in the same
> parent?

I had some nameless folders on the Bookmarks Toolbar as quick "buckets". Anyway, I agree it's a minor issue.

> We were going to be referencing folders with "path"-style names in several
> places, which is why it works this way.

That's what I first thought. But I filed this bug, because you can create multiple folders with the same name in Places.

Comment 4

12 years ago
I see a similar issue but with bookmarks not folders and not after import. Everyday, I add Mozillazine's new "The Official Win32 xxxxxxxxxx [Trunk] build is not yet out" thread to my Places Bookmarks Toolbar. And after some amount of time this bookmarks is renamed automagically from "The Official Win32 xxxxxxxxx [Trunk] build is not yet out." to "xxxxxxxxx Trunk" which is the name of one item in Peter's "The official win32 builds" Feed (I livemarked it).
Note my RSS feeds belongs to a folder on my Places Bookmarks Toolbar.

Comment 5

11 years ago
IMNSHO, this could be a feature rather than a bug.
Without this behavior, importing from a backup (for example) results in duplicating a huge number of bookmarks.

Comment 6

11 years ago
> I had some nameless folders on the Bookmarks Toolbar as quick "buckets".
> Anyway, I agree it's a minor issue.
> 
I used nameless folders in the same way. I can't agree that messing with user's data like that is a minor issue. If I had several folders, I expect to see them separate after upgrading.

The migration code could detect the folders with the same name and disambiguate them by adding [1], [2], etc to their names

> That's what I first thought. But I filed this bug, because you can create
> multiple folders with the same name in Places.

I just noticed that too, and I don't understand Brett's comment about this being "by design" anymore.
Flags: blocking-firefox3?
Version: unspecified → Trunk
Flags: blocking-firefox3? → blocking-firefox3+
Hardware: PC → All
Target Milestone: Firefox 2 beta1 → ---

Updated

11 years ago
Target Milestone: --- → Firefox 3 beta1

Updated

11 years ago
Target Milestone: Firefox 3 M7 → Firefox 3 M8
I can no longer reproduce this bug. IIRC, when we stopped merging imported bookmarks (in favor of appending per Fx2 behaviour), this went away.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
>when we stopped merging imported bookmarks (in favor of appending per Fx2 behaviour)

That was bug #381225: on import, places bookmarks builds attempt to merge in bookmarks.html, where firefox 2 appends bookmarks.

So marking this bug as fixed.  This is something we could add to the test suite(s).
Depends on: 381225
Flags: in-testsuite?
Flags: in-litmus?
Resolution: WORKSFORME → FIXED

Comment 9

11 years ago
verified with: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007073005 Minefield/3.0a7pre.

litmus has a general import test case that we need to break out into a few more detailed cases.
Status: RESOLVED → VERIFIED

Comment 10

10 years ago
Testgroup: 3.0 Full Functional Tests (FFTs)
Subgroup: FX 3.0 FFT - Import
Testcase: Bookmark folders with the same name merged after import
Product: Firefox
Branch: Trunk
Author email: darkmane@gmail.com
Steps to perform:
1) Create a folder: Test-Import-Folder
2) Create Bookmark A (http://www.google.com) in Test-Import-Folder
3) Export bookmarks to Import-test1.html
4) Delete Bookmark A from Test-Import-Folder
5) Create Bookmark B in (http://www.yahoo.com) Test-Import-Folder
6) Export Bookmarks to Import-test2.html
7) Delete Bookmark B and Test-Import-Folder
8) Import Import-test1.html
9) Verify that Test-Import-Folder is created and contains Bookmark A
10) Import Import-test2.html
11) Verify that only one copy of Test-Import-Folder exists and it contains Bookmark A and Bookmark B

Expected Results:
Only one copy of Test-Import-Folder exists and it contains Bookmark A and Bookmark B. Bookmark A and B do not exist anywhere else

Regression Bug ID#: 330025
Flags: in-litmus? → in-litmus+
Test case 7452 created to address regression issues for this bug in rel3.1.
(In reply to comment #11)
> Test case 7452 created to address regression issues for this bug in rel3.1.

Which is not a valid test. Should we remove it from Litmus?
I corrected the test case to reflect identical folders *not* being merged after import.
https://litmus.mozilla.org/show_test.cgi?id=7452
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.