Closed Bug 330026 Opened 14 years ago Closed 12 years ago

[rw] Kinyarwanda: Firefox

Categories

(Mozilla Localizations :: Registration & Management, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: steverwanda, Unassigned)

References

Details

Attachments

(6 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

This has already been requested once, in bug 289562 by Steve Murphy.

I have now taken over control of this project, and was advised to refile the bug report. We have now completed translation of all GUI files for Firefox 1.5.

Please advise on what further steps need to be taken.

Reproducible: Always
Note: Alt-key keyboard shortcuts aren't properly set yet, which means File menu appears as Idosiye (F) etc. This is in the process of being fixed, but I'm trying to get the ball rolling here.
Have just faxed CVS contributor form to Marcia Knous.
Fax form received. need voucher and SSH key added to this bug as well.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #214662 - Attachment mime type: application/octet-stream → application/zip
Attachment #214662 - Flags: approval-l10n?
Attachment #214664 - Attachment mime type: application/octet-stream → application/zip
Comment on attachment 214665 [details]
All remaining subdirectories of l10n/rw

putting one of these on the radar.
What version do these correspond to?
(It would be easier for us to just have one zip, btw)
Attachment #214665 - Attachment mime type: application/octet-stream → application/zip
I tried to upload all as one zip file, but it turned out bigger than 300kb so I thought I'd have to split it.

Version is 1.5. Were there any new strings for 1.5.0.1? I've tried to model the l10n/rw directory tree on those downloaded from cvs for l10n/en-GB, l10n/fr and l10n/de although these don't seem to be consistent amongst themselves.
I can vouch for Stephen, if that's allowed - I know him because we were at University together.

Gerv
Attached file review of rw (obsolete) —
Comment on attachment 216111 [details]
review of rw

sorry, wrong.
Attachment #216111 - Attachment filename: jdk-1_5_0_06-windows-i586-p-iftw.exe → darn
Attachment #216111 - Attachment is obsolete: true
This is the result of running compare-locales on the result.
Please us a current version of the 1.5 help files, too.

And a zip -9 on rw yiels just 370k, that should work as a single attachement.

Please fix the issues listed and attach a new version, and request approval-l10n
on that again.
Comment on attachment 214662 [details]
Here is a zip file of the l10n/rw/browser and l10n/rw/browser subdirectory of the main code tree

more to be done for all three of these.
Attachment #214662 - Flags: approval-l10n? → approval-l10n-
Still need the voucher and SSK key on this bug, and looks like we are still waiting on an outcome of Comment 13.
Yes, many apologies for the delay - our translation resources have been rather overstretched recently which means the translation of the help files and installation scripts has taken longer than I anticipated. I will hopefully be ready to re-submit within the next couple of weeks, however.

I'm still not entirely clear how I will get a voucher for this, as I don't know anyone within the Mozilla l10n arena. Would Axel be able to vouch once he's satisfied with the technical aspects of our work?

I'll get on to the SSH key tomorrow.

Cheers,
Steve.
Sorry for the lag on my side this time around, yes, I'll do the vouching.

Note, we won't take new locales on the 1.5.0.x branch anymore, the next target is 2.0.0.x, not sure if 2.0 itself will be in the timeline.
Once again my zip file registered at 309k and bugzilla refused to accept it as an attachment, so I've had to package it up as two. Apologies for inconvenience but the limit seems to be 300k and I can't find a way round it. 

This file contains translations for browser, dom, netwerk, other-licenses, security subdirectories of the l10n/rw directory based on a snapshot of CVS taken 12th September 2006.

As far as I can tell everything is translated except for the very latest changes to using_firebird.xhtml (which we are working on), and the file browser/os2/README.txt which doesn't seem to be translated in other locales.
The second part. Contains the toolkit subdirectory of l10n/rw as of 12th Sept 2006.
Set r? flags on those patches to get them on my radar?
Heads up warning, this is likely going to wait until we're out of general panic of locking down for fx 2.0.
Attachment #237992 - Flags: approval-l10n?
Attachment #237993 - Flags: approval-l10n?
I thought that might be the case, but we'll keep working and hope to target a release for version 2.0.0.1 if that's realistic?
Hi Axel,

Do you know how soon you can get around to looking at this, now that Firefox 2.0 is out of the door?

Regards,
Steve.
Let's move this bug to Registration, where it should really be.
Assignee: marcia → registration
Status: ASSIGNED → NEW
Component: CVS Account Request → Registration & Management
Product: mozilla.org → Mozilla Localizations
QA Contact: justdave → registration
Summary: l10n CVS account request: Kinyarwanda (rw-RW) → [rw] Firefox localization: Kinyarwanda (rw-RW)
Version: other → unspecified
Duplicate of this bug: 287493
Attachment #237992 - Flags: approval-l10n? → review+
Comment on attachment 237993 [details]
Kinyarwanda files for Firefox 2.0 (part two)

Ok, finally.

I'll do an r+ on these attachements. They're not complete, at least reporter is missing, but this is good enough to get things going.

Would you please fill in details on your team on http://wiki.mozilla.org/L10n:Teams:rw, similar to what I have done on http://wiki.mozilla.org/L10n:Teams:de?
Attachment #237993 - Flags: approval-l10n? → review+
Blocks: 370617
I filed bug 370617 for the CVS account, as this is merely about the registration, and bug 370618 for a bugzilla component.
Summary: [rw] Firefox localization: Kinyarwanda (rw-RW) → [rw-RW] Kinyarwanda: Firefox
Ok, this is moving forward. We're doing a whole lot of process changes right now, so I had to take a step back and look more closely again. And I needed some time to set this off, as taking a new locale does require some initial attention.

Stephen, I'd like to do the initial commit for you, as that's usually a tad tricky. Do you mind? Are the attachements in the bug a good start?

I'd still like you to fill in some information on the wiki page I mentioned in comment 24, too.

I filed bug 390145 to create a bugzilla component, in which I'll then file the remaining bugs to track the process 'til release.
Hi Axel,

That would be fine. Please check in the translations as attached. I will get onto the Wiki page shortly.

Steve.
Initial landing done.

There are two things missing right now, firstly, you'll need to incorporate the changes for bug 372409 for the migration wizard and then you'll need to translate reporter, still. Those files are in http://lxr.mozilla.org/mozilla1.8/source/extensions/reporter/locales/en-US/.

We'll fix these issues and the other bugs mentioned below on the trunk first before going onto the MOZILLA_1_8_BRANCH, though we'll make the rw trunk work against MOZILLA_1_8_BRANCH for en-US.

I hooked rw up on http://l10n.mozilla.org/buildbot/, which will automatically try to generate a language pack after each check-in for you to test. You can see the results of the automatic tests by going to the log of the comparison step, the current log is at http://l10n.mozilla.org/buildbot/linux-incubator/builds/5/step-moz%3Acomparelocales/0

I did three minor mods:
- bookmarks.html. We're pretty strict on the links, I replaced it with a slightly modified version of the en-US one. Please translate the link titles there. The pages bookmarks.html links to will be part of another bug, which will follow http://wiki.mozilla.org/L10n:Web_parts.
- searchplugins: I didn't check-in the xml files, as the build process will pick up the searchplugins that are the same as in en-US from that dir, thus you just needed list.txt. We'll review the searchplugins in another bug, too.
- rw/browser/chrome/help/.using_firebird.xhtml.swp: I removed that file again.

If you have further questions, you can ask for help in the newsgroup news://news.mozilla.org/mozilla.dev.l10n, or on #l10n, irc://irc.mozilla.org/l10n or by mail.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Summary: [rw-RW] Kinyarwanda: Firefox → [rw] Kinyarwanda: Firefox
You need to log in before you can comment on or make changes to this bug.