All users were logged out of Bugzilla on October 13th, 2018

Weird jumpy selection behaviour with richlistbox (e.g. extension manager and download manager)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: ria.klaassen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:
1. Open Extension Manager.
2. Resize it until you see a scrollbar.
3. Click on the first extension.
4. Scroll down with the slider and (right)click on the last one.
Result: it jumps, selecting sometimes the right but mostly the wrong extension. When you leftclick the right, and when you rightclick the wrong one.
I tried it with at least 24 extensions, so if someone needs it for testing I will attach them.
I'm unable to reproduce using the steps with 30 extensions. Are you using the default theme? Are you using any extension manager extensions (e.g. local install, nightly tester tools, etc.)?
(Reporter)

Comment 2

13 years ago
I see the sudden difference in behaviour between 1.9a1_2006030907 and 1.9a1_2006030912. I could reproduce it with 12 extensions, no theme amongst them.
I could also reproduce it with 14 other extensions. New profile, first run, default settings.
(Reporter)

Comment 3

13 years ago
No Nightly Tester Tools.
this is possibly event related - I suspect a regression from bug 234455
(Reporter)

Comment 5

13 years ago
I can narrow it down further: between 1.9a1_2006030908 and 1.9a1_2006030912, but it's still a lot:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2006-03-09+07%3A00&maxdate=2006-03-09+12%3A00
*** Bug 333663 has been marked as a duplicate of this bug. ***
Ria, can you check if the same behavior happens in the download manager? Thanks.
(Reporter)

Comment 8

13 years ago
(In reply to comment #7)
> Ria, can you check if the same behavior happens in the download manager?
> Thanks.
>
Yes, also in the download manager. 

Component: Extension/Theme Manager → XUL Widgets
Product: Firefox → Toolkit
QA Contact: extension.manager → xul.widgets
Summary: Weird jumpy selection behaviour in extension manager → Weird jumpy selection behaviour with richlistbox (e.g. extension manager and download manager)

Comment 9

13 years ago
*** Bug 335825 has been marked as a duplicate of this bug. ***
I backed out the patch from bug 328881 and was no longer able to reproduce this bug
My initial tests show that the patch in bug 334765 does indeed fix this. The richlistbox widget selection behavior on scroll seems to be a bit different (selection seems to lag whereas it didn't before) but I believe that can be fixed in the widget itself or it may be something specific to my system.
*** Bug 336098 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
it jumps back to the last selection if it is scrolled out of the window.
btw. the behavior of the first click after opening the ex-manager is always right.

very annoying...

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1a3) Gecko/20060529 BonEcho/2.0a3

(sry 4 bad English..)
The cause of this bug is known and the patch in bug 334765 fixes this bug.
This appears to be fixed by the checkin of bug 334765. Anyone confirm?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060615 Minefield/3.0a1 ID:2006061602
Clicking around the addons manager now works as expected for me; no weird jumping behaviour.
Well the majority of the problem is gone. Its still a bit wierd though if you have a large description extension selected above the extension you want to select. When you select the large extension obviously shrinks down leaving the extension you clicked on somewhat higher than it was when you clicked on it so your mouse is no longer over it.

Not necessarily a big problem though.
Resolving wfm though this was fixed by bug 334765.

re: large descriptions, etc. - we probably could calculate its top left position and retain that if there is room to scroll. I agree it is weird and that it isn't a big problem.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.