Mail not received by other end when add signature is checked

RESOLVED INCOMPLETE

Status

Thunderbird
Security
--
major
RESOLVED INCOMPLETE
12 years ago
9 years ago

People

(Reporter: Robert Pellerin, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-08-28)

Attachments

(1 attachment)

17.19 KB, application/x-compressed
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I recently deleted Outlook after email receipients stoped receiving emails, while the sending process gave no error, too happy of getting rid of Miscrosoft I installed Thunderbird. Everything was Ok with Thunderbird until imported my Thawthe certificate. Then the only messages which were geting their target were those encrypted. The other ones, signed or not never get anywhere, but the sending process gives no error and Thunderbird report that the message was sent. I updated to Thunderbird 3.0a1, whent back to 1.5 (french) removed my certificate, no change, mail doesn't get anywhere.

Solutions? Need more information?

Reproducible: Always

Steps to Reproduce:
1. Import Thawte Cettificate
2. Send mail to wour favorite alternate email
3. Try to get it.

Actual Results:  
None
(Reporter)

Updated

12 years ago
Summary: Mail no received after Thawte certificate import except if encrypted. → Mail not received after Thawte certificate import, except if encrypted.
(Reporter)

Comment 1

12 years ago
Created attachment 214852 [details]
3 typical messages

3 typical messages 1 plain text, the second signed, the tird encrypted with its received copy.
(Reporter)

Comment 2

12 years ago
After many attempts, it look like encrytped messages are the only ones which get their destination, hey can be encrypted S/MIME with my Thawte key and enigmail or OpenPGP.

I also noticed that the sending progression bar seems to last longer when the messages are encrypted. I put about the same quantity of characters in not encrypted message as an encrypted one is and it took less time to send the non encrypted one. The progression bar look like message is sent at half way while for encrypted messages youse it reaching the end.
(Reporter)

Comment 3

12 years ago
I was able to send a message after I uncheched the add signature to message in the configuration windows, when the message does not show the "-- + your name" at the end of the message they go thru.

I don't understand anymore.
(Reporter)

Comment 4

12 years ago
Finally, it look like is is not the signature itself which prevent the message from being received, it is the check box status in the accounts prefs. If the signature or the vCard are checked, the message never get to the receipient even if the signature is manually removed from the message body. At one point I was certain that the signature itslef was the cause because encrypting a message was removing the signature itself, but the answwer is somewhere else.
Summary: Mail not received after Thawte certificate import, except if encrypted. → Mail not received by other end when add signature is checked
Reporter, does the issue still occur in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest supported 2.0.0.x is 2.0.0.16)
Whiteboard: closeme 2008-08-28
RESO INCO per lack of response to the last question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.