Places window misses shortcut key "close" functionality

RESOLVED FIXED in Firefox 2 alpha2

Status

()

Firefox
Bookmarks & History
P1
normal
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Patrick, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({fixed1.8.1})

unspecified
Firefox 2 alpha2
PowerPC
Mac OS X
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
With places now being a window instead of a tab, it needs a way to close the window.

Concerning UI:
On my OS X, it misses the equivalent of a OK/CANCEL/CLOSE button, and the standard RED dot in the upper left corner for closing in a window is absent too. [Screenshot following...]

Concerning keyboard accessibility:
On my OS X, it doesn't respond to CTRL-W or ESC

Currenlty the only way seems to close Places seems to be to look up to the FILE menu.
(Reporter)

Comment 1

13 years ago
Created attachment 214775 [details]
A "places" window without close functionality.

There currently is no OK/Cancel/Close button in the places window, and the standard red OS X button for closing a window is disabled.

Comment 2

13 years ago
Bug gone in a 1 hour old homemade build on MacOS-X. FIXED ?!

Comment 3

13 years ago
Works for me in the build of the 11th.

The red dot works, and File->Close too. cmd-W (not ctrl W) is still missing. Escape shouldn't work at all (see bug 277544). Since it's a window and not a dialog box, there won't be any ok/cancel or close buttons.
(Reporter)

Comment 4

13 years ago
*** Bug 330155 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

13 years ago
Red button indeed comes up going from March 10 to March 11 build.
Also the menubar for places now has more options.

However, a key combination [CMD-W] is still missing.

Correcting typo in summary and focussing on shortcut key 
Summary: Places window missses "close" functionality → Places window misses "close" functionality
(Reporter)

Comment 6

13 years ago
Red button indeed comes up going from March 10 to March 11 build.
Also the menubar for places now has more options.

However, a key combination [CMD-W] is still missing.

Correcting typo in summary and focussing on shortcut key 
Summary: Places window misses "close" functionality → Places window misses shortcut key "close" functionality
Assignee: nobody → bugs
Priority: -- → P1
Target Milestone: --- → Firefox 2 alpha2
Fixed br & trunk
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Keywords: fixed1.8.1
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.