Status

()

Firefox
General
--
critical
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Lucy Bradford, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

After going to the website www.gametrailers.com for a short while, the memory usage goes very high, I think it's because the use of macromedia flash on the site. The browser will struggle to scroll up or down after time and navigation is slow. There are other problems, where by If I try to view a wmp video of a trailer on the site the browser will totaly crash. If I download a video, the browser will either crash or the download will stall at a very small % or somtimes 99% complete, the only fix is to close the browser in the process list, as closing the browser normaly and trying to open again, says it's already open. 

This also happens with general surfing for a prolonged amount of time, 3-4 hours the memory usage will jump from 34k to a high 300k and it somtimes uses 100% of my cpu, which makes my computer unusable, unless I cancel it in the process list. I took screen shots of this usage level...
http://img.photobucket.com/albums/v406/Woosy/Misc/firefox.jpg
http://img.photobucket.com/albums/v406/Woosy/Misc/firefox2.jpg

A list of sites I have this problem on range from...

www.ghostrecon.com
www.gametrailers.com
www.scifi.com/battlestar
www.scifi.com/atlantis
www.cbs.com/primetime/the_unit
www.ubi.com (community forums)
www.googlemail.com

I've had this memory leak problem since version 1.0, but this version is alot worse in terms of memory usage and gets to a point where the browser is not useable. I use two extensions I don't know if they are the culprit. They are Gmail Notifier v0.5.5.2 and IE View v1.2.7 I use one Theme called Aquatint v1.6.4

Another problem, If I have all those websites open in tabs and navigate in them, after a long time of use,the memory will go super high, if I close all but one tab the useage is still the same.
 



Reproducible: Always

Steps to Reproduce:
1. go to www.gametrailers.com
2. Navigate through game sections, Splinter Cell, Ghost Recon etc...
3. Watch a video or try downloading one and look at the usage figure.

Actual Results:  
The useage jumps from 35k to 65k-ish and over the time it's increases since I've been writing this bug over 10 minutes, it's now 170k and still rising. http://img.photobucket.com/albums/v406/Woosy/Misc/firefox3.jpg

Expected Results:  
It should load the page normaly, and navigate with low usage figures which I consider 35k reasonable. This doesn't happen in Internet Explorer or Opera that i've been forced to use as an alternative, which use a low 14-20k usage.

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-official-branding --enable-svg --enable-canvas --enable-update-packaging
Please read http://dbaron.org/log/2006-01#e20060110a and http://forums.mozillazine.org/viewtopic.php?t=354828 before filing bugs about supposed memory leaks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.