If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

UI: Keyboard navigation shortcuts as in 4.x

VERIFIED WONTFIX

Status

SeaMonkey
MailNews: Message Display
P3
enhancement
VERIFIED WONTFIX
18 years ago
13 years ago

People

(Reporter: Blandon Ray, Assigned: scottputterman)

Tracking

({access, polish})

Trunk
x86
All
access, polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
I didn't think this belonged under the umbrella bug for keyboard
shortcuts in the Browser component, so here it is:

Interested in seeing 4.x-style keyboard shortcuts in mailnews,
for accessibility and ease-of-use. Here are the ones I use often:

spacebar to next unread message if at end
N/P to next/previous message
n/p to next/previous unread message
+/- to expand/collapse threads
m to mark read/unread
tab to switch panes (did this move to another key?)

Comment 1

18 years ago
I think we have some other bugs on the keyboard shortcuts. cc: nbaca.  Can you 
find and mark dup as needed?  I think the other bugs may be more specific.   
Thanks.
QA Contact: lchiang → nbaca

Comment 2

18 years ago
I'm in the process of checking shortcut keys to ensure that they match what is 
documented in the current spec, which is different from 4.x. When logging these 
bugs I will place 'ui' in the "Keywords" field. I will also log them per window 
(i.e. 3-pane, NewMessage/Composer, Address Book). I will assign this bug to 
myself for now until some questions are answered. 

FYI: The spec differs from the 4.x implementation in some ways:
1. N=Next Unread Message
2. Shift+N= Next Message
3. P=Previous Unread Message
4. Shift+P= Previous Message
5. M=toggles between marked as read and unread

jglick: Can you clarify these questions?
6. +/- to expand and collapse threads appears in th 4.6 version on Linux only 
but are not in the current spec. Can you refresh my memory as to why this was 
removed?
7. Using the tab key to switch panes. What should the order be? I don't see this 
in the spec. Possibley:
- folder pane
- thread pane
- message pane
- sidebar

Assignee: selmer → nbaca
Summary: [FEATURE] Keyboard navigation shortcuts as in 4.x → [FEATURE] UI: Keyboard navigation shortcuts as in 4.x

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
Ninoschka, I assume you are referring to Lake's keyboard navigation spec?
http://gooey/client/5.0/specs/keyboard/kybdnav2.htm

Cc'ing Lake for verification and changes to spec as necessary.

>6. +/- to expand and collapse threads appears in th 4.6 version on Linux only 
>but are not in the current spec. Can you refresh my memory as to why this was 
>removed?

I don't know why they would be removed.  Seems like a good idea to me.  Would be 
nice if +/- worked for other platforms as well.


>7. Using the tab key to switch panes. What should the order be? I don't see 
this in the spec. 

Tab order should be:
- folder pane
- sidebar (if sidebar closed, this should be skipped)
- thread pane
- message pane

Comment 4

18 years ago
Correction, after talking to Lake, the tab order should be:

- folder pane
- thread pane
- message pane
- sidebar (if sidebar closed, this should be skipped)

Also, Lake mentioned that the envelop area should maybe be its own separate tab, 
so: Folder, Thread, Envelope, Message body, Sidebar.  So that users could tab to 
the different items in the envelop area.

Comment 5

18 years ago
Sorry to interrupt your flow, but this certainly belongs here. 3 shortcut keys
should be implemented (in both browser and mail): Ctrl + F for Find in page, and
Alt + arrows for Back and Forward rather than the non-standard ones Mozilla has
introduced. These have become universal.

Comment 6

18 years ago
Lake: After tabbing into the Envelope area, how should its elements be accessed 
such as "Add to Address Book" button and "Attachments"?
Assignee: nbaca → putterman
(Assignee)

Comment 7

18 years ago
I know that nbaca will be working on this. I'd prefer a bunch of bugs by area 
rather than one generic bug for the entire product.  I'm also removing the 
feature since this is more polish.
Status: NEW → ASSIGNED
Summary: [FEATURE] UI: Keyboard navigation shortcuts as in 4.x → UI: Keyboard navigation shortcuts as in 4.x
Target Milestone: --- → M18

Comment 8

17 years ago
A few more bindings for this window which I really miss from 4.x:

u for mark unread
spacebar going to next message if we're already at the end
shift-[mod]-r for replyall
g for mark group unread
t for mark thread unread (not that important unless we get + for expandall working)

Nominating for nsbeta3 since key accelerators make a big difference in usability.
Keywords: nsbeta3, polish
(Assignee)

Comment 9

17 years ago
we already have a bug for spacebar.  t already marks a thread as read and 
ctrl+shift+r already does reply all.
(Assignee)

Comment 10

17 years ago
mail triage marking nsbeta3-. We wil open up individual bugs for the ones we
need to fix. We aren't fixing u and g.  space bar has a bug and the other two
should work.
Whiteboard: [nsbeta3-]
Keywords: access

Updated

17 years ago
Target Milestone: M18 → ---

Comment 11

16 years ago
I think this should be marked WONTFIX

No one is using this bug - individual bugs are being opened for each keyboard
problem in the mailnews interface.

Comment 12

16 years ago
Resolved Wontfix since other bugs have been logged to track additional issues.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 13

16 years ago
Verified Wontfix.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.