"view source" doesn't view source of focused window while composing mail

RESOLVED INVALID

Status

P3
normal
RESOLVED INVALID
19 years ago
14 years ago

People

(Reporter: spam, Assigned: cbegle)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Had roamed around on web and clicked a "mailto" link so the mail-composer was

opened. Then clicked on the browser window to activate it - right-clicked in it

and selected "view source". A new mailcomposer window with the address filled in

for the one i was writing to opened instead of what i expected (namely the

source of the webpage i was on)



Seems the page has to be reloaded to view the source i want. And when i clicked

back-button, the copy of the mail-compose window again popped up.



Also worth mentioning is the fact that a "view page source" NEVER presents the

source of the page currently downloaded, but instead downloads the page again

from web and then presents it in the source-view window. This means that the

source i browse can contain changes if the page was altered in the meantime.

(Very often the case with various dynamically loading pages). I'd expect the

source to show me what's currently in the browser window - not something else.

And I'm on PPP - if i disconnect i can't browse source at all - i just get an

error message stating url "could not be found - check the name and try again" :(
dark@c2i.net - we need your Build ID please :-) Also, it would be great if you 
could use Bugzilla Helper http://www.mozilla.org/quality/help/bug-form.html to 
report bugs.

The following actions:
Load a page.
Click a "mailto:" link
Bring focus back to browser
Context Menu | View Source

Does the Right Thing for me on 20000324 Win95 (apart from the fact View Source 
is broken for me; but that's another issue). Are these actions what you mean?

Gerv
(Reporter)

Comment 2

19 years ago
I think the description is pretty clear. Build was 0323.
But as they say - i'm outta here. Setting this invalid and wishing the
developers good luck.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 3

19 years ago
dark@c2i.net, are you still seeing the bug
if you are still seeing the bug with a newer build please reopen and maybe we 
can find the probelm.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.