Flash animation in background tab plays music

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Matthias Bohnen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Having two tabs open, with each tab containing a flash animation, both flash animations play their music simultaneously.

Reproducible: Always

Steps to Reproduce:
1. (for example) go to www.addictinggames.com
2. open at least two flash animations (that play music) in tabs.

Actual Results:  
All flash animations play their music simultaneously.

Expected Results:  
Only the flash animation that has the users focus should be allowed to play music.

You need to have a flash plug-in installed to experience this bug. 

I don't think this is a bug of the flash plug-in, because i guess only Firefox knows which flash animation is in the foreground tab, so Firefox has to handle this.

But I am unsure if Firefox has control over the sound output from flash plug-ins...
Firefox has no control over the sound from the flash plugin and this is IMHO no bug, it's by design

This bug is invalid (and btw: it should be the same with 2 open windows)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.