Closed Bug 330385 Opened 14 years ago Closed 14 years ago

"My Timezone" doesn't seem to remember timezone setting, but it still behaves correctly

Categories

(Calendar :: Lightning Only, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: keria, Assigned: jminta)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Lightning 0.1 RC2 (build: 2006031011)

The My Timezone tab in Calendar options the currently selected timezone isn't selected as it should be. Still it seems to behave correctly

Reproducible: Always

Steps to Reproduce:
1. Options, Calendar, My Timezone tab
2. Select timezone, close Options dialog box.
3. Go back to options and there is no timezone selected.


Expected Results:  
Have the currently selected timezone selected.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Patch moves the code to do the selection outside of the while loop.  Adding additional after the select created problems which doing the select at the end solves.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #216320 - Flags: first-review?(dmose)
Comment on attachment 216320 [details] [diff] [review]
move select out of while loop

r=dmose
Attachment #216320 - Flags: first-review?(dmose) → first-review+
Patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.