Composer Format menu: Mac submenus broken

VERIFIED FIXED in M16

Status

()

Core
Editor
P1
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Joe Francis, Assigned: saari (gone))

Tracking

({pp})

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.61 (Macintosh; I; PPC)
BuildID:    

Bring up Composer.  Click in the Format menu.  Notice that you can't pull up any 
of the submenus.  If you try submenus in other menus first, they are fine.  But 
after you try the Format submenus, all other composer submenus will refuse to 
popup.

Reproducible: Always
Steps to Reproduce:
1. launch composer
2. try to use Fromat menu submenus


Actual Results:  submenu failed to appear.  Other Composer submenus then also 
refuse to appear.

Expected Results:  submenu appears.

mac only?

Comment 1

19 years ago
cc saari; Chris--could this be a problem with reusing menus from toolbars and 
main menus?
Target Milestone: --- → M15

Comment 2

19 years ago
I see nothing wrong in the XUL or JS to cause this.
It is Mac-only, so it's better handled by Simon (it's probably really an
XPFE bug.)
Assignee: cmanske → sfraser

Comment 3

19 years ago
reassign to saari (the menu guru) since sfraser has other priority bugs at the 
moment
Assignee: sfraser → saari
Keywords: pp
Summary: Composer Format menu: submenus broken → Composer Format menu: Mac submenus broken
(Assignee)

Comment 4

19 years ago
This is pretty strange. 

Status: NEW → ASSIGNED
Priority: P3 → P1

Comment 5

19 years ago
Hint: on switching windows with the composer window up, I've seen 
"PageBackground" or somesuch flick up in the menu bar as a top-level menu on the 
right of the usual menu items. Kinda odd, and looks like a menu is getting 
parented wrong.
(Assignee)

Comment 6

19 years ago
looks like it is related to the oncreate stuff on the format menu

Comment 7

19 years ago
Mass-moving most M15 bugs to M16
Target Milestone: M15 → M16
(Assignee)

Comment 8

19 years ago
Fix in hand. Tree is closed.
Whiteboard: fix in hand
(Assignee)

Comment 9

19 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 10

18 years ago
verified in 4/11 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.