Opening a PDF file freezes the browser

RESOLVED DUPLICATE of bug 253117

Status

()

RESOLVED DUPLICATE of bug 253117
13 years ago
13 years ago

People

(Reporter: bilaribilari, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I use Adobe ACrobat 7.x. Whenever a PDF document URL is clicked, the adobe acrobat plugin opens the file in the tab window itself and during this action, the entire browser just freezes. Only after the document has loaded, does the browser start responding again. For small docs, this is acceptable, but for big ones, over an MB or so, its a headache.

Reproducible: Always

Steps to Reproduce:
1.Configure firefox action to open PDF using the plugin
2.Go to a url that has a PDF file (considerably large > 1MB)
3.

Actual Results:  
Browser freezes and goes unresponsive until the document is loaded (or maybe, until the plugin is loaded - finishes its own initialisations)

Expected Results:  
Document should have continued to load while the rest of the browser remains responsive. Probably some threading issue.

Comment 1

13 years ago
Duplicate of Core bug 305463 -> Core bug 253117.

*** This bug has been marked as a duplicate of 253117 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.