unable to read encrypted email if "fetch headers only" is selected

RESOLVED DUPLICATE of bug 329955

Status

--
major
RESOLVED DUPLICATE of bug 329955
13 years ago
13 years ago

People

(Reporter: adesmailbox-bugzilla, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1)
Build Identifier: version 1.5 (20051201)

If you have ticked "fetch headers only2 and receive an encrypted email (using a certificate), then you get a decryption error before you can select "Click here to download the rest of the message" and so cant open the email

Reproducible: Always

Steps to Reproduce:
1. Tick "fetch headers only"
2. Send an email that is encrypted with a certificate
3. Try to open

Actual Results:  
You will receive "Thunderbird cannot decrypt this message" where the body of the email would be

Expected Results:  
You should be given an option to download the body of the email, before thunderbird tried to decrypt it

You should either have a chance to click on "Click here to download the rest of the message" or encrypted emails should automatically download the body

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 329955 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.