Canvas drawImage corrupts PNGs with indexed transparency

RESOLVED DUPLICATE of bug 320510

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 320510
12 years ago
12 years ago

People

(Reporter: Erryn Pollock, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Attempting to draw any indexed transparent PNG onto a canvas results in the image being horribly corrupted. Any method of "grabbing" the source image or drawing it on the canvas has the same effect. Non-transparent indexed PNGs draw correctly.

Reproducible: Always

Steps to Reproduce:
1. Draw a transparent indexed PNG onto a canvas by any method.
2. Observe the corrupted image.

Actual Results:  
Image is corrupted.

Expected Results:  
The image should have been drawn correctly.

I'll attach a test case.
(Reporter)

Comment 1

12 years ago
Created attachment 215029 [details]
A simple test case.
(Reporter)

Comment 2

12 years ago
Created attachment 215030 [details]
Test image for testcase.
(Reporter)

Comment 3

12 years ago
Also seems to be an issue with transparent GIFs, but I haven't tested this as thoroughly.
(Reporter)

Comment 4

12 years ago
For some reason I didn't see the dupe when I searched originally. I'll clean up my own mess, but the test case might still be useful.

*** This bug has been marked as a duplicate of 320510 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.