Improperly closed A causes FONT to close too soon.

VERIFIED FIXED in mozilla0.8

Status

()

P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: chrispetersen, Assigned: harishd)

Tracking

({top100})

Trunk
mozilla0.8
top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-](contacted webmaster@weather.com -- ianh 2000-08-08), URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Version: Apprunner
Build: 2000032305
Platform: Mac
Other Platforms:Need to check on Windows and Linux.
Expected Results: The Font element (size attribute) should be applied to
enclosed text.

What I got: The font element is closed early because of a improperly closed A.

Steps to reproduce:

1) Open attached test case in Apprunner. This test case was distilled from
weather.com.
2) The font element is using the SIZE attribute assigned a "1" value.
3) This size is applied to the first and second lines only. The third line
is render at the default size.
4) The problem is with the second line. The A is closed inside FONT instead of
outside. This apparent closes the beginning font element.
(Reporter)

Comment 1

19 years ago
Created attachment 6848 [details]
A font element containing an A that is not closed properly

Comment 2

19 years ago
Changing component to Parser
Assignee: troy → rickg
Component: Layout → Parser
QA Contact: petersen → janc
(Reporter)

Updated

19 years ago
QA Contact: janc → petersen
(Reporter)

Updated

19 years ago
Summary: Improperly closed A cause FONT to close too soon. → Improperly closed A causes FONT to close too soon.

Updated

19 years ago
Target Milestone: --- → M17

Updated

19 years ago
Target Milestone: M17 → M18

Comment 3

19 years ago
*** Bug 33407 has been marked as a duplicate of this bug. ***
Isn't this something that should be fixed in the source HTML and not in the browser?
(Assignee)

Comment 5

19 years ago
Moving to my list wince Rickg is on sabbatical.
Assignee: rickg → harishd
(Assignee)

Comment 6

19 years ago
Top 100 sites. Ought to be fixed for beta3.
Status: NEW → ASSIGNED
Keywords: nsbeta3
(Assignee)

Comment 7

19 years ago
Marking top100.
Keywords: top100
OS: Mac System 9.0 → All
Hardware: Macintosh → All
Whiteboard: (contacted webmaster@weather.com -- ianh 2000-08-08)

Comment 8

19 years ago
Marking nsbeta3- and evangwanted...

This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration, but do not clear 
the nsbeta3- nomination.
Keywords: evangwanted
Whiteboard: (contacted webmaster@weather.com -- ianh 2000-08-08) → [nsbeta3-](contacted webmaster@weather.com -- ianh 2000-08-08)
Target Milestone: M18 → Future

Updated

18 years ago
Keywords: evangwanted
(Assignee)

Updated

18 years ago
Target Milestone: Future → mozilla0.8
(Assignee)

Comment 9

18 years ago
Created attachment 24623 [details] [diff] [review]
Patch v1.1 [ r=jst sr=vidur]
(Assignee)

Comment 10

18 years ago
Fix is in. Marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

18 years ago
Marking verified in the March 23 build (2001032304).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.