misleading scheme handling for url without "//" (relative URIs are confusing)

RESOLVED INVALID

Status

()

Core
Networking
--
enhancement
RESOLVED INVALID
12 years ago
5 years ago

People

(Reporter: harblafoobar, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1



Reproducible: Always

Steps to Reproduce:
for example active page "http://www.example.org/" contains this links:

<a href="ftp:www.example2.org/">ftp</a>
<a href="http:www.example2.org/">http</a>
<a href="www.example2.org:80/">open in tab</a>
Actual Results:  
first link: ftp://kernel.org/

second link: http://www.example.org/kernel.org/

third link:
left-click: Warning... no protocol "www.example.org"
middle-click open in new tab: http://www.example.org/

Expected Results:  
first link:
- no link; not clickable
- or ftp://www.example2.org/www.example.org/ like http

second link: maybe no link; not clickable

third link:
- warning on middle-click

rfc3986 => 3.1. Scheme:
When presented with a URI that violates one or more scheme-specific restrictions, the scheme-specific resolution process should flag the reference as an error rather than ignore the unused parts; doing so reduces the number of equivalent URIs and helps detect abuses of the generic syntax, which might indicate that the URI has been constructed to mislead the user (Section 7.6).

=> 3.2. Authority
The authority component is preceded by a double slash ("//") and is terminated by the next slash ("/"), question mark ("?"), or number sign ("#") character, or by the end of the URI.

so this problems are not "scheme-specific" (authority-specific) but this is an "abuses of the generic syntax"

Updated

12 years ago
Component: General → Networking
Product: Firefox → Core
Version: unspecified → Trunk
QA Contact: general → networking

Comment 1

5 years ago
This is how browsers deal with URLs (unfortunately): http://url.spec.whatwg.org/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
Resolution: INVALID → DUPLICATE
Summary: misleading uri/scheme handling → misleading scheme handling for url without "//" (relative URIs are confusing)
Duplicate of bug: 362259

Comment 3

5 years ago
Jesse, this is not about scheme-relative URLs. This bug is about

http:google.org with a http://mozilla.org/ base URL producing http://mozilla.org/google.org which is an unfortunate reality the web depends upon.
Resolution: DUPLICATE → INVALID
You need to log in before you can comment on or make changes to this bug.