Message deleted when DEL is wrongly pressed while viewing in message window

RESOLVED WONTFIX

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED WONTFIX
12 years ago
4 years ago

People

(Reporter: Elio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Double click a message then, while viewing the msg in the main window, try to press the DEL key. The message will be deleted and then (wrongly) the window will show the next message... It's too easy make a mistake since the system doesn't advertise the user that the msg has going to be deleted. In this window I would only read the message and not manage the message database! I think this is an unexpected behavior.

Reproducible: Always

Steps to Reproduce:
1. Open message window by double clicking the msg in main window
2. Press DEL while viewing
3.

Actual Results:  
Message deleted with no prompt

Expected Results:  
Message not deleted at all, or, at least, pop-up a box asking for deleting confirmation.

Comment 1

12 years ago
(In reply to comment #0)
> Expected Results:  
> Message not deleted at all

You can't be serious.


> at least, pop-up a box asking for deleting confirmation.

This is the same as Seamonkey bug 172128.  As noted there, the message is in your Trash folder, so you can reclaim it.  (That bug has been resolved as a duplicate of bug 179891, but I think that duplication was erroneous.)
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → WONTFIX
Version: unspecified → Trunk

Updated

11 years ago
Duplicate of this bug: 308063
Assignee: mscott → nobody
QA Contact: front-end

Updated

4 years ago
See Also: → bug 308063
You need to log in before you can comment on or make changes to this bug.