Firefox gets unresponsive and eats a lot of CPU time and memory (jpeg_free_large)

RESOLVED DUPLICATE of bug 335715

Status

()

--
critical
RESOLVED DUPLICATE of bug 335715
13 years ago
6 years ago

People

(Reporter: iik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I can't reproduce it but on a regular basis (a few times a week) it happens that Firefox gets totally unresponsive but isn't crashing. I noticed if you wait long enough (up to one hour) it comes back. But normally i kill Firefox using the Task-Manager. Please take a look at the screenshots. Everytime this happens jpeg_free_large is stressing the CPU. Investigations should start there.

I also noticed Flash-movies sometimes when the bug occours. But that's just a guess.

Reproducible: Didn't try

Steps to Reproduce:
Tricky to reproduce: Try to open complex sites, lots of them, flash-, quicktime-, wmp-plugin-based sites. Keeping Firefox open for some hours should also help. Sorry for this vague description.



System Specs: Athlon64 3000, 1 GB RAM, WinXP SP2
(Reporter)

Comment 1

13 years ago
Created attachment 215194 [details]
cpu_usage_history
(Reporter)

Comment 2

13 years ago
Created attachment 215197 [details]
threads/jpeg_free_large

Comment 3

13 years ago
Bug 303972 is also about high CPU usage by jpeg_free_large, duplicate?

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 335715 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.