Mail headers Content-Type and Content-Disposition are not conform to RFCs 2045 and 2231

RESOLVED DUPLICATE of bug 323318

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 323318
12 years ago
12 years ago

People

(Reporter: devconsole, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060226 Debian/1.5.dfsg+1.5.0.1-3 Firefox/1.5.0.1
Build Identifier: Thunderbird 1.5 (Windows/20051201)

I have received an e-mail from Thunderbird 1.5 that contains the following headers (in an attachment):

Content-Type: application/vnd.ms-excel;
 name*0*=ISO-8859-15''R%FCckstellung%20DB%2C%20DZ%20u.%20KommSt%202001-2004
 name*1*=.xls
Content-Transfer-Encoding: base64
Content-Disposition: inline;
 filename*0*=ISO-8859-15''R%FCckstellung%20DB%2C%20DZ%20u.%20KommSt%202001-
 filename*1*=2004.xls

The header parameters name*0* and filename*0* should be terminated with a semicolon (";") because of RFC 2045 which defines:

content := "Content-Type" ":" type "/" subtype
                *(";" parameter)

RFC 2231 says that "the mechanism MUST NOT change the syntax of MIME media type and disposition lines...". Therefore the semicolons are mandatory.

Please check also the errata of RFC 2231 which includes the semicolons in all examples: http://ietfreport.isoc.org/idref/rfc2231/

Reproducible: Always

Steps to Reproduce:
1. Create an e-mail and attach a file with a very long filename that contains special chars
2. Send the e-mail to yourself
3. View message source

Actual Results:  
E-mail contains "folded" parameters in Content-Type and Content-Disposition that are not terminated by a semicolon (";")

Example:
Content-Type: application/vnd.ms-excel;
 name*0*=ISO-8859-15''R%FCckstellung%20DB%2C%20DZ%20u.%20KommSt%202001-2004
 name*1*=.xls

Expected Results:  
Content-Type: application/vnd.ms-excel;
 name*0*=ISO-8859-15''R%FCckstellung%20DB%2C%20DZ%20u.%20KommSt%202001-2004;
 name*1*=.xls

Comment 1

12 years ago
Should be fixed in nighty builds (branches and trunk).

*** This bug has been marked as a duplicate of 2045 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 2

12 years ago
Wrong dupe:(
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 323318 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.