The unseen Resolution default of "---" on b.m.o causes search problems

VERIFIED FIXED

Status

()

bugzilla.mozilla.org
General
--
minor
VERIFIED FIXED
12 years ago
7 years ago

People

(Reporter: exodus systems, Assigned: justdave)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)
Build Identifier: 

The advanced search page on b.m.o has resolution defaults of Duplicate and "---" pre-selected upon entry.

Because of the size of the html table area, the "---" is off the screen.

One of the most common uses of the Advanced search page is to check whether there are existing bugs before reporting one.  In such a case, the resolution default of duplicate is NOT helpful at all, and so is de-selected.

However, one has to remember to scroll down and de-select the "---" , otherwise it is quote common to get a zero bugs found result when in fact bugs exist.

I suggest that the deault statuses of duplicate and "---" should NOT be pre-selected upon entering the advanced search page.

Thanks.

Reproducible: Always

Steps to Reproduce:
1. Access the Advanced Search Page
2.
3.

Actual Results:  
Returns "zero results" which appears incongruous with data selected in visible search fields.  (it is of course NOT a BUG per se, but certainly darned irritating !)
It's set this way quite on purpose....  the default settings select all open bugs and all bugs resolved as duplicate, which provides the result set most-likely to contain bugs someone is searching for when they're looking to see if something is already filed.

Perhaps the best option here is to make the select box bigger so you can see that it's selected already.  I've done that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 2

12 years ago
claiming that a duplicate isn't an existing bug is being unaware of how things work. it is not unreasonable or unlikely for a search to turn up a duplicate and not the bug against which it has been resolved.

verify fixed the widgets are all taller which has significantly improved usability.  i believe this was a regression from "someone" introducing EXPIRED without considering all the ramifications.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

12 years ago
Dave/timeless,

Thanks for updating the search page table size.  Definitely simplest solution.

Dave must confess to not understanding your comment "the default settings select all open bugs and all bugs resolved as duplicate, which provides the result set most-likely to contain bugs someone is searching for when they're looking to see if something is already filed."

For this to be accurate, I assume that "---" is shorthand for "all open statuses" ?  If so, where is this explained/documented in help or on b.m.o ?

Also, what about where a bug has been reported once and solved - it is neither open, nor duplicate .. hence why I tend to deselect the pre-selections as I want to search EVERYTHING to see if it has already been reported, not just if someone ELSE has previously reported something when they didn't search thoroughly enough and their report was labelled duplicate.

Timeless I am well aware that a duplicate is a bug :).. basically I wanted to search ALL statuses, and the defaults preclude some. It's not that I wanted duplicates excluded, it's that I wanted everything INCLUDED, and as it appeared on the screen, it appeared that ONLY duplicates were selected.

Again, am not suggesting that any further change be made.  Solution is fine. Just needing/giving clarification. :-)

Warren Kinny.
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.