Add Live Bookmark context doesn't always show all options

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
9 years ago

People

(Reporter: Kwan, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Sometimes when clicking on the "Add Live Bookmark..." button in the Location bar it will bring up a context menu of available feeds, and other times it will just pick one.  It has been present since upgrading to 1.5 from 1.0.7, and depends on the given mimetypes in the type attribute.

Reproducible: Always

Steps to Reproduce:
1. Add 3 link elements to the header of a HTML document with rel="alternate"
2. Give each a different type, application/rss+xml, text/xml, application/atom+xml
3. Open document in Firefox and click on the "Add Live Bookmark..." icon in the Location bar 

Actual Results:  
The "Add Live Bookmark" box comes up asking you to pick a name and location for the bookmark.

Expected Results:  
Context menu showing:
<ul>
<li>Add 'RSS 2.0' as Live Bookmark...</li>
<li>Add 'RSS 0.92' as Live Bookmark...</li>
<li>Add 'Atom 1.0' as Live Bookmark...</li>
</ul>

Adding a fourth feed with a mimetype matching any of the other 3 will cause the context appear, as can be seen in later test cases.  I also discovered 2 other bugs.  The first occurs when you have 2 application/atom+xml and 2 (application/rss+xml|text/xml), in which case Firefox will only display the Atom ones in the context (see test cases 8 and 9).  The second is 2 application/rss+xml and 2 text/xml, in which case which ever mimetype comes first will be the only one registered (see test case 10).

I originally found this out using WordPress as the news CMS for a band fansite.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5.0.x Branch
Component: Menus → RSS Discovery and Preview
QA Contact: menus → nobody
That's not a bug, it's a feature. If you have a case where different feeds (not just different formats of the same feed) are being hidden, then you have a duplicate of bug 309085, but not prompting people to make a choice between Atom, RSS 2.0, RSS 1.0, and RSS 0.92, when there's no practical difference for Live Bookmarks (they all have titles and links, and we just throw out the rest) is not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Resetting QA Contact to default.
QA Contact: nobody → rss.preview
You need to log in before you can comment on or make changes to this bug.