Closed Bug 330798 Opened 16 years ago Closed 13 years ago

URL makes FF lag into oblivion by CLNavBar Java applet

Categories

(Core Graveyard :: Java: OJI, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mnemo, Assigned: yuanyi21)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When I surf to this site:
http://publib.boulder.ibm.com/html/as400/v4r5/ic2924/info/db2/rbafzmstcrtcoll.htm

The page starts to download and render properly, but halfway through it starts to operate slowly. This process continues and it gets worse and worse. It affects all FF windows and if I let it continue it completely bogs down all browser windows. I waited for a very long time and it does not seem like it stops but rather that it holds the browser bogged down unresponsive in some obscure endless loop or something?


Reproducible: Always

Steps to Reproduce:
1. Surf to http://publib.boulder.ibm.com/html/as400/v4r5/ic2924/info/db2/rbafzmstcrtcoll.htm
2. Wait 2-5 seconds.
3. All Mozilla windows becomes totally unresponsive.




This bug is critical for this particular page because it causes a complete browser crash (essentially) but I just mark it as MAJOR anyway because it's only this URL that is affected afaik (probably other pages with similar html/technology too).
It (almost) hanged on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060317 Firefox/1.6a1 (non-Cairo trunk w/ Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)) with very high CPU load but not crashed. Probably caused by a Java applet.

I tried it in IE and the applet CLNavBar loaded without hanging, though the applet itself seems not to work correctly without showing navigation items.
Status: UNCONFIRMED → NEW
Component: General → Java: OJI
Ever confirmed: true
Product: Firefox → Core
Summary: URL makes FF lag into oblivion → URL makes FF lag into oblivion by CLNavBar Java applet
Version: unspecified → Trunk
Assignee: nobody → yuanyi21
QA Contact: general → zhayupeng
I see a brief slow responsive spot of about 2 seconds, but otherwise fine

WFM 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.