User facing errors shouldn't talk about QA if QA contact is disabled

RESOLVED FIXED in Bugzilla 2.22

Status

()

Bugzilla
User Interface
--
trivial
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: timeless, Assigned: Vlad Dascalu)

Tracking

2.20.1
Bugzilla 2.22
Bug Flags:
approval +
approval2.22 +

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
[% ELSIF error == "user_has_responsibility" %]
    [% title = "Can't Delete User Account" %]
    [% admindocslinks = {'useradmin.html' => 'User administration'} %]
    The user you want to delete is set up for roles as default [% terms.bug %]
    assignee or QA contact for at least one component.
    For this reason, you cannot delete the account at this time.

Updated

12 years ago
Severity: enhancement → trivial
OS: MacOS X → All
Hardware: Macintosh → All

Updated

12 years ago
Whiteboard: [Good Intro Bug]
(Assignee)

Updated

12 years ago
Assignee: general → vladd
Status: UNCONFIRMED → NEW
Component: Bugzilla-General → User Interface
Ever confirmed: true
(Assignee)

Comment 1

12 years ago
Created attachment 224206 [details] [diff] [review]
Patch, v1
Attachment #224206 - Flags: review?
(Assignee)

Comment 2

12 years ago
Created attachment 224209 [details] [diff] [review]
Patch, v2

Colin (on IRC) seems to prefer this version.
Attachment #224209 - Flags: review?

Comment 3

12 years ago
Comment on attachment 224209 [details] [diff] [review]
Patch, v2

r=me by inspection
Attachment #224209 - Flags: review+

Comment 4

12 years ago
I wonder if the "up" shouldn't be there - "is set as the default"... but (personally) I'd think that could be fixed at checkin stage.
(Assignee)

Updated

12 years ago
Attachment #224209 - Flags: review?
(Assignee)

Updated

12 years ago
Attachment #224206 - Flags: review?

Updated

12 years ago
Attachment #224209 - Flags: review+

Updated

12 years ago
Status: NEW → ASSIGNED
Flags: approval?
Flags: approval2.22?
Target Milestone: --- → Bugzilla 2.22
(Assignee)

Comment 5

12 years ago
Comment on attachment 224206 [details] [diff] [review]
Patch, v1

Personally I liked version 1 better because it talked about "roles".

In the future we might support plugin or extensions that allow custom fields in which the value is a Bugzilla username. If we have such field with a default user value, deleting the user will bring up this message as well. In this case, we need to talk about generic "default user roles", and probably give the assignee as an example.

Version 2 is ok as long as the only possible roles are assignee or QA contact, but this is going to be short-lived, so probably it's worst than the current version.
(Assignee)

Comment 6

12 years ago
Regarding the previous comment, I'm leaving the approval request for version 2, it's just that we must be careful and change the message once we support additional default user roles. But for the current code it's ok and it fixes what timeless requested.
Flags: approval?
Flags: approval2.22?
Flags: approval2.22+
Flags: approval+
(Assignee)

Comment 7

12 years ago
BUGZILLA-2_22-BRANCH:

Checking in template/en/default/global/user-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/user-error.html.tmpl,v  <--  user-error.html.tmpl
new revision: 1.145.2.14; previous revision: 1.145.2.13
done

Trunk:

Checking in template/en/default/global/user-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/user-error.html.tmpl,v  <--  user-error.html.tmpl
new revision: 1.172; previous revision: 1.171
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Whiteboard: [Good Intro Bug]
You need to log in before you can comment on or make changes to this bug.