If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Search Messages could be much faster

RESOLVED DUPLICATE of bug 295088

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 295088
12 years ago
12 years ago

People

(Reporter: Mattias, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: TB version 1.5 (20051201)

Search messages should "short circuit" the search if "match all of the following" is selected.  For example, if I put in "from" "contains" "somebody", then the search is fast.  If I add another line with "body" "contains" "something" then it is slow.  It appears every email body is searched, not just the emails that match the first line.  This could be made faster by "short circuiting" the search, in the order the search criteria are listed, and just searching the results that match each line.  This should also work with more than two lines of search criteria.

Reproducible: Always

Steps to Reproduce:
1. Use "Search messages" with >1 criteria, the first criteria if used alone should be a fast search, the last criteria being "body" "contains" "something"
2. Set "Match all of the following"
3. Click Search
Actual Results:  
Search takes >40 seconds

Expected Results:  
Search takes <2 seconds

Comment 1

12 years ago
please try a nightly trunk build - but that reminds me, I should port that change to 2.0...

*** This bug has been marked as a duplicate of 295088 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.