Msgs incorrectly marked as read by two different actions

RESOLVED DUPLICATE of bug 284030

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED DUPLICATE of bug 284030
12 years ago
12 years ago

People

(Reporter: Peter Karp, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Thunderbird version 1.5 (20051201)

In this bug, a mail message that should be marked as
Unread is incorrectly marked by Thunderbird as Read.
I have found two ways to duplicate this problem.
Here is one sequence of actions:

1. Begin with View:Unread
2. Click on some unread message to display its contents
3. Now click on the button to the left of the message to
manually mark it as Unread.
4. Now manually select View:All

The message will change its status from Unread to Read.

A second way of triggering this bug is:

1. Begin with View:All and with a search defined to select
all messages whose Subject Or Sender contains Smith.  
2. Click on a message from Smith to read it.
3. Now manually mark the message as Unread.
4. Now clear the search so that all messages are displayed.

The message from Smith will now be changed by Thunderbird
from status Unread to Read.  

I argue that in both of the above cases, the message
status should not change.  I use "Unread" status to help
track tasks that I need to do later.  This behavior by
Thunderbird can cause me to lose tasks that need to be
done.  So in that sense I am losing data, which is why
I mark the bug as critical.






Reproducible: Always

Comment 1

12 years ago
If you really believe this is a critical bug, you probably should be using somebody else's software.

*** This bug has been marked as a duplicate of 284030 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.