Memory leak when accessing E4X object

RESOLVED DUPLICATE of bug 330169

Status

()

Core
JavaScript Engine
--
major
RESOLVED DUPLICATE of bug 330169
12 years ago
12 years ago

People

(Reporter: Doug Wright, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
Simple stuff like

var xml = <foo><bar>foobar1</bar><bar>foobar2</bar></foo>;
var foobar = xml.foo.bar[0];

causes a memory leak. Every time |xml| is referenced, memory leaks. My XULapp which makes heavy use of E4X currently leaks 1.5Gb RAM in 4 minutes due to this.

Testcase coming up.
(Reporter)

Comment 1

12 years ago
http://www.dougweb.org/bugzilla/330857.html (testcase with large XML source so the leak is easy to see)

http://www.dougweb.org/bugzilla/330857.zip (zipped version of above)

Comment 2

12 years ago
Do you see the leak with the latest CVS/nighty builds? This can be the same issue as one from bug 330169 fixed on 2006-03-15.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Do you see the leak with the latest CVS/nighty builds? This can be the same
> issue as one from bug 330169 fixed on 2006-03-15.
> 

latest-trunk appears to have this fixed (my last trunk testing had been with 2006-03-14). I'll dupe this.
(Reporter)

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 330169 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.