allow maxVersion=2.0 or 3.0 for trunk and branch nightly builds

RESOLVED FIXED in 1.0

Status

addons.mozilla.org Graveyard
Administration
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: myk, Assigned: morgamic)

Tracking

unspecified

Details

(Reporter)

Description

12 years ago
Thunderbird 1.8 branch and trunk nightly build versions have been bumped to 2.0a1 and 3.0a1, respectively, and Firefox build versions will be similarly bumped very soon, but addons.mozilla.org won't accept the submission of extensions with compatible maxVersions (f.e. with maxVersions set to 2.0 or 3.0).

It would be useful for addons.mozilla.org to accept such submissions, because then nightly and upcoming alpha testers could test their favorite addons with the new versions of the applications and report problems.  It also makes the applications easier to dogfood for engineers who use extensions regularly, and more dogfooding means higher quality.

Please allow maxVersions of 2.0 and 3.0 (or their equivalents) so that extensions which are compatible with such nightly builds (and the upcoming alphas) can be uploaded to addons.mozilla.org.
(Assignee)

Comment 1

12 years ago
Added 2.0 and 3.0 for Tb and Fx addon developers will now be able to set a MaxVersion of 2.0/3.0.

Arguably, though, I still doubt why MaxVersion even exists if people can set it to something in the way distant future.

Maybe we should consider removing it, and only applying a MaxVersion when we know a given extension breaks if used in a client version > x.

It might be worth discussing further.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.