Extension installation (multiple operations - drop xpi in extensions dir and deletion of existing install) fails

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
13 years ago
10 years ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Steps to reproduce:
1. Have an old version of an extension in your folder extensions.
2. Delete that version and put the new .xpi in the folder.
3. Run Firefox.
4. Firefox will show the dialog but no extension will be installed.

See screenshots.
(Reporter)

Comment 1

13 years ago
Created attachment 215440 [details]
screenshot 1
(Reporter)

Comment 2

13 years ago
Created attachment 215441 [details]
screenshot 2
What do you mean by "delete that version" ?
Does it install properly if you just place the xpi in the extensions directory without deleting the existing directory for the extension to be installed? I suspect it does... what I think is happening is the deletion of the extensions directory creates a uninstall operation and the addition of the xpi for that same extension never gets the install operation.

If this is the case then this bug is an extreme edgecase and for myself is wontfix.
The screenshot shows the extension directory still there when the startup detects the xpi so I'm not sure it's that case.
The directory is created by getItemLocation on startup prior to the uninstall.
Summary: Extension installation (replacement by a newer version) fails → Extension installation (multiple operations - drop xpi in extensions dir and deletion of existing install) fails
The code that performs the different operations doesn't handle multiple operations on the same item intentionally since supporting multiple operations such as this is not necessary and would require a significant amount of additional logic which would most likely lead to a additional bugs. In this instance, if you want to install or upgrade an extension using the file drop method just drop the file into the extensions directory without deleting the old extension install.

resolving -> wontfix
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.