Closed Bug 330906 Opened 19 years ago Closed 19 years ago

Switching to History (Last Visit Date) takes very long

Categories

(Firefox :: Bookmarks & History, defect, P2)

x86
Windows XP
defect

Tracking

()

RESOLVED WORKSFORME
Firefox 2 beta1

People

(Reporter: ria.klaassen, Assigned: brettw)

References

Details

Attachments

(1 file)

Steps to reproduce:
1. Click on Places icon. The window will take five seconds to appear.
2. Then click Bookmarks menu and then switch to History again. It will take another five seconds to reappear.
The same history (By Last Visited) in pre Places builds takes only one second to appear (history.dat 3.04 MB). And the second time it appears almost immediately.
How much history are you seeing in the window when it appears?
(In reply to comment #1)
>
All history I think.
same problem for me. i had 70mb history.dat file, therefore never used history. but at least all my history was in autocomplete list. firefox was freezing for about 1-2 seconds when typing first letter into addressbar once after run. now it is happening every time i enter first letter into addressbar.

sorry for bad english. hope it is understandable.
(In reply to comment #3)
> same problem for me. i had 70mb history.dat file, therefore never used history.
> but at least all my history was in autocomplete list. firefox was freezing for
> about 1-2 seconds when typing first letter into addressbar once after run. now
> it is happening every time i enter first letter into addressbar.

This bug does not have anything to do with autocomplete. See bug 320181.
Ria, was places always this slow or is this a regression? If it was always this slow, I think this is a WONTFIX, unfortunately. I don't know of any way to speed this up. Viewing all your history will just be slow. We need to be careful in the UI so it's not very easy to get to all your history unless you reall want it.
Assignee: nobody → brettw
Priority: -- → P2
Target Milestone: --- → Firefox 2 beta1
(In reply to comment #5)
>
Sorry for the late reply. For some reason the bugmail was not sent to me.
I don't know if this is a regression, for only since a few days I see all history when I open Places. Previously I saw the calendar which displayed only today's history.

There is also another huge problem: when I use the sidebar extension, it takes 7 seconds before the history is displayed in the sidebar. When I close it, it seems wiped out of the memory, for when I reopen it takes another 7 seconds again. The behaviour is comparable with Places. During this seconds, Firefox freezes. Wouldn't it be better if the history stayed in the memory? Memory enough, but my processor can't handle this very well. Although is a 1400 MHrz processor. I think this is average.

The only way out is to keep it always open which is not my habit. It is not very much history. Within a few days you gather easily something like 3 MB.

Would be nice if Firefox showed only the last 7 days in "By Last Visited" order with a "Show more history..." on the bottom. I think only one day is too little, especially when the day has just begun. 
Since the calendar is not longer there, history loads very heaviy.
I miss the Go-menu terribly because in a tweaked state it showed always the last visited 100 items, also the ones that I visited the previous day. Although the Go-menu was not perfect because it did not update the list instantly after revisiting an address but only after a browser restart. I think the idea of the Go-menu was very good but not the implementation. 
This is no longer the case.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: