Closed Bug 330914 Opened 14 years ago Closed 10 years ago

Command Line AddressBook Disables Size & Maximize System (Control) Menu Items

Categories

(Thunderbird :: Address Book, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.1b1

People

(Reporter: martimus8, Assigned: standard8)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

When executing "thunderbird.exe -addressbook" under Windows 2000 or Windows XP...resize and maximize option is disabled (greyed out) in the System (Control) menu.  If "thunderbird.exe" is executed, then click on toolbar address book, items are enabled.

I'm assuming the command line execution of the address book opens the window with incorrect window type.

If a user accidentally sizes the addressbook window too small in this mode, it will disable the ability to ever resize it since the lower, right, resize tool is "hidden"...A user is able to recover from this by launching thunderbird.exe, and selecting address book from toolbar, then resize the window.

NOTE: This feature does NOT exist under Mandriva LE2005/LE2006/PowerPack2006 and this is a confirmed feature on 4 machine with no extensions loaded (e.g. clean profile)

Reproducible: Always

Steps to Reproduce:
1.Open thunderbird.exe -addressbook, click system menu, see disabled options
2.Open thunderbird.exe normally, click addy book, click sys menu, see enabled options described in the details section.
3.Open with commandline switch, resize to minimum size, and pull your hair out when you can't resize it so one can see it...read this bug report, see work-around, and shake head ;) :)

Actual Results:  
Addressbook window only allows sizing in lower, right corner and once a user resizes too small, covering up the sizing corner, unable to resize unless user loads thunderbird directly and clicks addy book toolbar item, and resizes it there.

Expected Results:  
thunderbird.exe -addressbook should always have sizing handles around all borders of the window, as well as statusbar most likely should always be visible if this is the intended action of resizing an addressbook window.

Again, feature is not present in Mandriva Linux LE2005/LE2006/2006 PowerPack
(In reply to comment #0)
Oh and one additional note: Thunderbird 1.5 for Windows...sawwy
Version: unspecified → 1.5
Bumped the version of Thunderbird up to 2.0 (2.0.0.6 20070728) for this bug...

This problem is STILL PRESENT on Windows XP (still NOT a problem in Mandriva 2007.1 PP with KDE)
Version: 1.5 → 2.0
Assignee: mscott → nobody
Duplicate of this bug: 463362
confirming. I see this using trunk. someone else can determine cause and whether this is desirable or not.

xref 
- bug 361047 (which is now WFM)
- Bug 264488 (Customize Toolbars window should not have maximize or minimize buttons) ... which describes situation where max/resize is not desirable
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 2.0 → 1.5
Duplicate of this bug: 540286
Attached patch Proposed fixSplinter Review
Fixes -addressbook, -news and possibly -compose. AFAICT Window watcher's OpenWindow doesn't support the "all" attribute. Therefore we have to be a bit more explicit about what actually gets included when we open the window.

This patch switches the features options to match those of Thunderbird's toOpenWindowByType (which should in theory end up the same as SeaMonkey's one that does "all,chrome,dialog=no" I hope).

I'm don't think there's a reasonable unit test for this at the moment as we have no structure for opening Thunderbird with different command line parameters.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #422120 - Flags: superreview?(neil)
Attachment #422120 - Flags: review?(neil)
Comment on attachment 422120 [details] [diff] [review]
Proposed fix

>     wwatch->OpenWindow(nsnull, DEFAULT_CHROME, "_blank",
>-                       "chrome,dialog=no,all", arg, getter_AddRefs(opened));
>+                       "chrome,extrachrome,menubar,resizable,scrollbars,status,toolbar",
>+                       arg, getter_AddRefs(opened));
You don't need this because you're passing an arg, and this switches OpenWindow from window.open to window.openDialog mode, which does support all.

>     wwatch->OpenWindow(nsnull, "chrome://messenger/content/", "_blank",
>-                       "chrome,dialog=no,all", nsnull, getter_AddRefs(opened));
>+                       "chrome,extrachrome,menubar,resizable,scrollbars,status,toolbar",
>+                       nsnull, getter_AddRefs(opened));
But for the other two, the only way to avoid listing all the styles would be to pass in a fake argument (which we actually do in the suite command line handler but the indirection we have there makes it less obviously ugly.)
Attachment #422120 - Flags: superreview?(neil)
Attachment #422120 - Flags: superreview+
Attachment #422120 - Flags: review?(neil)
Attachment #422120 - Flags: review+
Checked in: http://hg.mozilla.org/comm-central/rev/dcb1f72cd83d

Note: waving the test requirement as we don't currently have startup tests (let alone with command line arguments).
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1b1
You need to log in before you can comment on or make changes to this bug.