Seamonkey crashes/quits as soon as I put in thie URL and try to browse.

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: vikram_jai, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060316 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060316 SeaMonkey/1.5a

The page seems to load completely i.e. images/code everything but as soon as its done - Seamonkey crashes without warning.

Reproducible: Always

Steps to Reproduce:
1.Open Seamonkey
2.Use Ctrl+L to go to address bar
3.Put in www.quicksales.com.au and press enter

Actual Results:  
Page loads and then immmediately after that Seamonkey crashes.

Expected Results:  
Page should have loaded succesfully and Seamonkey should not have crashed.

Having several other tabs open with other sites and having something like this happen is a major problem. I did use the feedback agent(talkback) but unfortunately do not have any more info on it.

Comment 1

13 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060317 SeaMonkey/1.5a
Java(TM) 2 Platform Standard Edition 5.0 Update 6

Please verify your current Java installation: http://java.com/en/download/installed.jsp

Does the page load if Java is disabled? See Edit->Preferences->Advanced or about:config browser.java.usePlugin and security.enable_java
(Reporter)

Comment 2

13 years ago
When I filed the bug I was running JRE 1.5.0_04.
On trying to run the test for JRE installation (http://java.com/en/download/installed.jsp), Seamonkey simply exited without warning.

I did rerun the JRE test in IE which reported that I had _04.

I have since undated the JRE to _06 which is the latest and Seamonkey still crashes irrespective of the fact whether Java is enabled or not.

However after updating JRE, the java update site seems to function properly reporting that I have the latest editon of JRE but quicksales still does'nt work.

Any success replicating the same behaviour?? or is it my system thats awry??

Comment 3

13 years ago
did you install the java update using Mozilla, or using IE?
Please type about:config into the location bar, and 'plug' (without the quotes) into the Filter: line
Select plugin.expose_full_path using right-click and toggle it to TRUE.

other relevant settings:
plugin.scan.SunJRE default string 1.3  (means Java 1.3 and younger will be searched for)

plugin.dont_try_safe_calls user set boolean false (don't know if relevant)

browser.java.usePlugin user set boolean true


Please type about:plugins into the location bar or select it from the Help menu. you should see something like:

Installed plug-ins

Java(TM) 2 Platform Standard Edition 5.0 Update 6
    File name: C:\Programme\Java\jre1.5.0_06\bin\NPJava11.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)
MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.1.1 	Java Applet 		Yes
application/x-java-bean;version=1.1.1 	JavaBeans 		Yes
application/x-java-applet;version=1.1 	Java Applet 		Yes
application/x-java-bean;version=1.1 	JavaBeans 		Yes
application/x-java-applet 	Java Applet 		Yes
application/x-java-bean 	JavaBeans 		Yes


and some more like this, until

Java(TM) 2 Platform Standard Edition 5.0 Update 6

    File name: C:\Programme\Java\jre1.5.0_06\bin\NPJPI150_06.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;jpi-version=1.5.0_06 	Java Applet 		Yes
application/x-java-bean;jpi-version=1.5.0_06 	JavaBeans 		Yes
Java(TM) 2 Platform Standard Edition 5.0 Update 6

    File name: C:\Programme\Java\jre1.5.0_06\bin\NPOJI610.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-vm 	Java 		Yes

File name: of course should reflect your path, not mine.


Comment 4

13 years ago
I can confirm, it happens also on my Linux build:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060316 SeaMonkey/1.5a

It is however not showing on my windows Firefox build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060318 Firefox/1.6a1

/be
(Reporter)

Comment 5

13 years ago
(In reply to comment #3)
> did you install the java update using Mozilla, or using IE?
I had to use IE because SM would not load up the test applet/install.

> Please type about:config into the location bar, and 'plug' (without the quotes)
> into the Filter: line
> Select plugin.expose_full_path using right-click and toggle it to TRUE.
> 
**DONE**

> other relevant settings:
> plugin.scan.SunJRE default string 1.3  (means Java 1.3 and younger will be
> searched for)
**Yep, default string is 1.3**

> plugin.dont_try_safe_calls user set boolean false (don't know if relevant)
** I don't have this option**
 
> browser.java.usePlugin user set boolean true
** I don't have this option**
But I can use edit->prefs to change if Java is used or not.

Any reason why I don't have these  options???

> 
> 
> Please type about:plugins into the location bar or select it from the Help
> menu. you should see something like:
> 
> Installed plug-ins
> 
> Java(TM) 2 Platform Standard Edition 5.0 Update 6
>     File name: C:\Programme\Java\jre1.5.0_06\bin\NPJava11.dll
>     Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)
> MIME Type       Description     Suffixes        Enabled
> application/x-java-applet;version=1.1.1         Java Applet             Yes
> application/x-java-bean;version=1.1.1   JavaBeans               Yes
> application/x-java-applet;version=1.1   Java Applet             Yes
> application/x-java-bean;version=1.1     JavaBeans               Yes
> application/x-java-applet       Java Applet             Yes
> application/x-java-bean         JavaBeans               Yes
> 
> 
> and some more like this, until
> 
> Java(TM) 2 Platform Standard Edition 5.0 Update 6
> 
>     File name: C:\Programme\Java\jre1.5.0_06\bin\NPJPI150_06.dll
>     Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)
> 
> MIME Type       Description     Suffixes        Enabled
> application/x-java-applet;jpi-version=1.5.0_06  Java Applet             Yes
> application/x-java-bean;jpi-version=1.5.0_06    JavaBeans               Yes
> Java(TM) 2 Platform Standard Edition 5.0 Update 6
> 
>     File name: C:\Programme\Java\jre1.5.0_06\bin\NPOJI610.dll
>     Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)
> 
> MIME Type       Description     Suffixes        Enabled
> application/x-java-vm   Java            Yes
> 
> File name: of course should reflect your path, not mine.
> 

Output on my system(truncated):

Java(TM) 2 Platform Standard Edition 5.0 Update 6

    File name: NPJPI150_06.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

Java(TM) 2 Platform Standard Edition 5.0 Update 6

    File name: NPOJI610.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

Java(TM) 2 Platform Standard Edition 5.0 Update 6

    File name: NPJava11.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

Java(TM) 2 Platform Standard Edition 5.0 Update 6

    File name: NPJava12.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

ava(TM) 2 Platform Standard Edition 5.0 Update 6

    File name: NPJava13.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

Java(TM) 2 Platform Standard Edition 5.0 Update 6

    File name: NPJava14.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

Java(TM) 2 Platform Standard Edition 5.0 Update 6

    File name: NPJava32.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

All of them are enabled.

Let me know if you need more info.
thx

Comment 6

13 years ago
After my tonight's build on Linux:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060319 SeaMonkey/1.5a

I can report that the bug is no longer there. So the CVS checkins made between the 16th and 19th March 2006 seem to have solved the problem.
So, at least it works for me

/be

Comment 7

13 years ago
dear sir:
please do not sign /be

there is no reason to sign comments as bugzilla explicitly indicates who you are and when you wrote your comment. unforunately there is already a /be signer in bugzilla and your introduction of a /be signature that does not represent him risks significant confusion.
(Reporter)

Comment 8

13 years ago
I have now installed the build dated the 18th.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060318 SeaMonkey/1.5a

The bug is now gone.

Plese mark this as fixed.

Thx everyone.

Comment 9

13 years ago
Marking WFM (Works For Me) according to reporter's comment #8
FIXED is for bugs, which are actually fixed by some known changes to the source code or build process.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.