Please restore the "Headers" tab to the Page Info dialogue.

RESOLVED DUPLICATE of bug 81202

Status

()

Firefox
Page Info Window
RESOLVED DUPLICATE of bug 81202
12 years ago
12 years ago

People

(Reporter: a_geek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060203 MultiZilla/1.8.1.0p SeaMonkey/1.5a Mnenhy/0.7.3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

Mozilla Suite, and SeaMonkey, have a Headers tab in the Page Info dialogue which allows finding out the request and response headers for a given page at a glance. This tab is entirely missing from Firefox, but dead useful if you're a developer.

Reproducible: Always




Why was it dropped in the first place?

Not tagging as enhancement because it's no new feature, but an old one instead.

Comment 1

12 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060316 Firefox/1.6a1

Whilst you may find support for your request, which is a perfectly good one, you
would probably do better to use the LiveHTTPHeaders Extension for your 
development work.

*** This bug has been marked as a duplicate of 81202 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

12 years ago
Hello, thanks for the hint, but I'm well aware of the LiveHTTPHeders extension, at least for SeaMonkey where I have it installed. I find this extension to tend to go "overboard" and being a bit clumsy in handling/not always doing what I want, and it's generally like driving a truck to fetch  only a six-pack.
I'm also a bit hesitant to install yet another extension (I have 32 active ones in already, plus a few which are incompatible, but which I can't de-install) which all take away from Firefox' responsiveness and managabiltiy, and also all require maintenance. Oh well...

Comment 4

12 years ago
Bug 81202 "view|page info should show HTTP headers" has not been WONTFIXed and 
there is at least one patch under consideration.

Certainly your request is a reasonable one.

This looks to me like like extension material, and the fact the the existing
extension is complex and has much functionality is not a good reason to have
it rolled into the core. Would you want all 32 of your extensions rolled in,
together with their management and responsiveness budget? What about your
neighbours 32 extensions?

FWIW LiveHTTPHeaders is open source and you can either fix its problems or
fork it ...
(Reporter)

Comment 5

12 years ago
Hello, the biggest problem for me personally is that I didn't yet get deep enough into the extension system to be able to create code. The barrier of entry looks high to me, and if you speak about porting etc - I'd rather port some FF extensions to SeaMonkey (FireBug comes to mind :-)). Ok, while I'd like to see this functionality in FF and still think it should have been there when I first looked for it, there is no real problem because I still have SeaMonkey AND LiveHTTPHeaders.
(Reporter)

Comment 6

12 years ago
FWIW, the LiveHTTPHeaders extension is marked compatible only with FF 1.0, not 1.5.
You need to log in before you can comment on or make changes to this bug.