Selecting bookmark from bookmarks menu loads previous selected bookmark

RESOLVED DUPLICATE of bug 329337

Status

()

P2
major
RESOLVED DUPLICATE of bug 329337
13 years ago
9 years ago

People

(Reporter: stephen, Assigned: annie.sullivan)

Tracking

unspecified
Firefox 2 alpha2
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: swag: ???)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20060318 Firefox/2.0a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20060318 Firefox/2.0a1

This is the same as bug 330301 which is marked as dup of bug 329337. But the fix is only applied to the trunck while branch still has the same issue. 

Reproducible: Always
(Reporter)

Updated

13 years ago
Severity: normal → major
(Reporter)

Updated

13 years ago
Component: Bookmarks → Places
Hi Josh, 

Do you have any ideas about how we can get a fix for this on the branch? 
Assignee: nobody → bugs
Priority: -- → P2
Target Milestone: --- → Firefox 2 alpha2
Whiteboard: swag: ???

Comment 2

13 years ago
Annie said she had a workaround at the Places level last time I talked to her (around the time I landed the patch on the trunk). Did that not work out?
Annie says she fixed this a couple of weeks ago. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

13 years ago
Just tried "Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20060404 Firefox/2.0a1 ID:2006040406" and the issue is still there. So, no, it's not fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Assignee: bugs → annie.sullivan

Comment 5

13 years ago
I can confirm that it's not fixed on the branch.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20060409 Firefox/2.0a1

In the main bookmarks menu (the one you pull down from the menubar), it will always load the url you selected in the next-to-last action. So the first time, you have to select twice. And when you then load a 3th one, you get the first url gain (from the second action.

Strangely enough, I don't see this behaviour in any of the submenus. And the 'bookmark memory' seems to belong to the main menu. After several attempts in the submenus, when I selected an url in the main menu, I still got the latest url-selection I did in the main menu, beforte I started to play in the submenus.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I also see a similar issue with non-browser windows - sometimes bookmarks menu items work on second access only. Josh, what's the reasoning behind not porting the orginal patch to the branch?

*** This bug has been marked as a duplicate of 329337 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 8

13 years ago
It involved API changes to widget/public/nsIMenuItem.h
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
You need to log in before you can comment on or make changes to this bug.