Images are cut when scrolling without smooth scrolling

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: Candid Dauth, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

When scrolling down on a web page without smooth scrolling, images are look very strange.

Reproducible: Always

Steps to Reproduce:
1. Disactivate smooth scrolling.
2. Go to http://www.ferienwohnungen-herrenberg.com/
3. Scroll down to the bottom.

Actual Results:  
Images look as shown in http://files.cdauth.de/bugs/firefox_1.png

Expected Results:  
Images should be shown as they are, which is when you scroll down by using the scroll bar or smooth scrolling.
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060318 Firefox/1.6a1 ID:0000000000
Works for me.
Can you reproduce this when running Firefox in safe mode? (http://kb.mozillazine.org/Safe_Mode)
(Reporter)

Comment 2

12 years ago
Yes, in safe mode, it's the same.
Can you reproduce this with the latest official Mozilla build of Firefox?
Version: unspecified → 1.5.0.x Branch

Comment 4

12 years ago
I can see same bug. Better shown on long pages like this http://tools.wikimedia.de/~daniel/WikiSense/Gallery.php?wikifam=commons.wikimedia.org&since=-1hmax=25

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Status: UNCONFIRMED → NEW
Ever confirmed: true
This happens with sufficent frequency that I'm sure there must be numerous dupes.  (I'll look for them momentarily.)  Here's another place where it happens quite a bit:
http://www.galionlibrary.org/news/
Reproducability is near 100% at that site, on at least the following platforms:  Ubuntu, FreeBSD, Win98SE, WinXP Pro.  This is all with the 1.5 series (including 1.5.0.6 on Ubuntu), although I think it may actually be rather older.  I have not tested it with Bon Echo, however.

Additional info:
* It actually can also happen with general.smoothScroll set to true, but under different circumstances.  With smoothScroll false, it happens when scrolling with scrollmouse buttons or the scrollbar, but _not_ with pgup/pgdn.  When smoothScroll true, it happens with pgup/pgdn but _not_ with scrollmouse buttons or the scrollbar.  I have not tested "autoscroll" with either setting.
* As near as I can determine, it (at least usually) only happens with images that contain alpha-channel transparency, although the effect is on the whole image, not just the transparent areas.  Fully opaque images such as photographs do not normally manifest the problem.
Anybody want to see testcases?

First testcase:  problem does _not_ manifest itself:
http://www.galionlibrary.org/tests/moz-png-scrolling-one.html

Second testcase:  problem _does_ show up:
http://www.galionlibrary.org/tests/moz-png-scrolling-two.html

There are only minimal differences between these two documents, and I am almost certain that it is the differences in the CSS that trigger the problem to show up or not.  HTH.HAND.
I've confirmed that the problem _does_ show up on ff 2.0b2 (e.g. using the testcases in the previous comment), but I was unable to reproduce it on the trunk nightly I tried (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060918 Minefield/3.0a1).

Comment 8

8 years ago
Bug seems to be fixed in Firefox version 3.6.6.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

8 years ago
Also doesn’t occur here anymore in Firefox 3.5.6.
You need to log in before you can comment on or make changes to this bug.