The default bug view has changed. See this FAQ.

mailman spam filter on lists.mozilla.org doesn't work

RESOLVED WORKSFORME

Status

mozilla.org Graveyard
Server Operations: Projects
P1
normal
RESOLVED WORKSFORME
11 years ago
2 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Assigned: justdave)

Tracking

Details

I administer dev-tech-crypto@lists.mozilla.org, 
also known as mozilla.dev.tech.crypto@news.mozilla.org

The newsgroup is unmoderated, but the list is moderated.
Email from list members gets right through without moderation.
The intent is that I hope to catch the occasional legitimate 
on-topic message that comes from a non-member address, and allow it 
to pass.  But all the spam should be discarded.  I don't even want to
be asked to review it.

I have setup mailmain 2.1.5's spam filter set up to detect and
DISCARD emails whose subjects contain certain spam keywords using the 
regular expressions shown below.

^subject:.*award
^subject:.*postcard
^subject:.*congratulation
^subject:.*lotto
^subject:.*lottery
^subject:.*lucky
^subject:.*winn
^subject:.*business.proposal
^subject:.*business.concern
^subject:.*verify.*account
^subject:.*charity
^subject:.*promotion
^subject:.*save.my.soul
^subject:.*\*\*\*SPAM\*\*\*
^subject:.*Update.Credit.Card
^subject:.*in.your.country
^subject:.*INVESTMENT.PROPOSAL
^subject:.*LEGITIMATE.TRANSACTION
^subject:.*GOOD.DAY!!!

Trouble is: this spam filter seems to have no effect.  Despite being
setup as shown, every day I get numerous emails with subjects like these:

POSTCODELOTERY
PROMOTIONAL DEPARTMENT
YOUR EMAIL WON THE LOTTERY
AWARD NOTIFICATION PRIZE!!
AWARD WINNING PROMOTION.

Maybe the problem is that the spam filter regular expressions are 
case sensitive?  (that would be quite useless)

If I could see the files on l.m.o, maybe I could diagnose the problem myself.  
But as long as they remain closed to me ...
http://ftp.redhat.com/pub/redhat/linux/updates/enterprise/4AS/en/os/SRPMS/mailman-2.1.5.1-34.rhel4.2.src.rpm

That's what we're running.  We have made local modifications, but they're mostly cosmetic, and nothing has gone near the spam controls.
OK, case-sensitivity isn't the issue, I just checked the source, and it is passing the IGNORECASE flag to the regexp match when it runs it.
(Reporter)

Comment 3

11 years ago
RPMs from redhat, eh?
Does mofo/moco pay redhat for software support?
(Reporter)

Comment 4

11 years ago
I should clarify one thing.  I wrote:  Despite being
setup as shown, every day I get numerous emails with subjects like these:

I should have written, ... numerous emails with subjects like these show
up in the list of messages awaiting moderation.  They are not discarded.
Assignee: server-ops → justdave
Priority: -- → P1
This still happening?
(Reporter)

Comment 6

11 years ago
Dave, two weeks after I filed this bug, I took drastic action to deal with 
loads of apparently unfiltered spam.  I changed the configuration for the
list to simply discard all email from non-subscribers, and not keep any of
it for "moderation".  That's not an alltogether satisfactory solution either,
because now I have no way of find the occasional (but rare) email that really
should go through, and forwarding it.  But this workaround is the lesser of 
two evils, in my opinion.

If you've taken some corrective action, I'm willing to reconfigure those 
accounts to stop discarding all non-subscriber email, and test the spam 
filter again for a few days.   Have you taken corrective action?
Component: Server Operations → Server Operations Projects
(Reporter)

Comment 7

11 years ago
10 days ago, when I added the previous comment to this bug, I restored the
spam filter.  The spam filter is supposed to discard any emails that 
match any of its regular expressions.  But since then, I still find emails
in the moderation queue, waiting to be approved, that clearly should have
matched one (or more) of the spam regular expressions.  

For example, one of the spam regular expressions (shown in comment 0) is
^subject:.*winn

That surely should have matched this email subject:
Subject: World Spring Luckyday Winner...
but it didn't.

So, in answer to comment 5: yes, this is still happening.
(Reporter)

Updated

11 years ago
Summary: lists.mozilla.org spam filter doesn't work → mailman spam filter on lists.mozilla.org doesn't work
A year later, let's try again.

This still happening?
Closing as WORKSFORME. If this is still an issue, please reopen.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.