submit button on one tab submits data from other tab

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: kew akl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060316 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060316 SeaMonkey/1.5a

looking at entries on multiple tabs from the URL, when I click on a button on one tab, the data from another tab is submitted.

Reproducible: Always

Steps to Reproduce:
 1.goto http://www.jobsearch.org/ 
 2.select a Job Category from list on the left
 3.provide zip code or location info  -> Search Now
 4.on the Resuts page, 
  right-click a Job Title entry - Open Link in New Tab
  right click another Job Title entry(hopefully a very different subject) - Open   Link in New Tab
 5.change to one of the newly opened tabs.
 6.make note of the Company Job ID number.
 7.goto the other new tab/make note of the Company Job ID or Job Title
 8.go back to previous tab/scroll to the bottom
 9.click on the 'Apply Now' button
10.notice that the data in this tab now reflects the entry from the OTHER tab.

The thing to consider is that the 'Apply Now' button submits data from the **last-opened** tab (NOT the last positioned tab) at this site
Actual Results:  
I get a page of info related to entry on another tab

Expected Results:  
I should get a page of info related to the entry from the current tab

Comment 1

12 years ago
The site uses a cookie to track what job you're looking at and updates the info whenever you open a job listing.  "Apply Now" simply pulls up the last job you opened.  You can verify this by opening a job listing,  deleting the cookie (tools->Cookie Manager->Manage Stored Cookies) for jobsearch.org and then clicking "Apply Now".  You'll get a blank page.

There's nothing SeaMonkey can do.  The site is not designed to handle the actions you're taking.

resolving INVALID -- not a Mozilla bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 2

12 years ago
*** Bug 331000 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.