Closed Bug 331054 Opened 15 years ago Closed 15 years ago

Gnome File Handler a Martian on KDE

Categories

(Firefox :: Shell Integration, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 298848

People

(Reporter: mozillabugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051128 SUSE/1.5-0.1 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051128 SUSE/1.5-0.1 Firefox/1.5

For whatever reason, later builds of FF have used the Gnome file browse dialog rather than the old XUL or a properly-integrated QT browse.  This is confusing and asthetically displeasing in the extreme, and makes no sense given the inferiority of the Gnome file browser compared even to the XUL version.  Please make visible an option to either revert, or use native browser.  Preferred solution would be a revert, as it will be a lot simpler to implement.

Reproducible: Always

Steps to Reproduce:
1. Use KDE
2. Launch Firefox
3. Go to File, Open
4. Wonder why this ugly brown thing is on your screen

Actual Results:  
Gnome file browse dialog appears

Expected Results:  
XUL or KDE browse dialog appears
XUL filepicker? WONTFIX in various duplicate places, including bug 300884. Qt filepicker? That'd be bug 298848.

*** This bug has been marked as a duplicate of 298848 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.