Last Comment Bug 331099 - Add .cat to IDN TLD whitelist
: Add .cat to IDN TLD whitelist
Status: RESOLVED FIXED
: fixed1.8.0.4, fixed1.8.1
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: ---
Assigned To: Daniel Veditz [:dveditz]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-20 06:17 PST by Gervase Markham [:gerv]
Modified: 2006-04-30 22:54 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v.1 (760 bytes, patch)
2006-03-20 06:45 PST, Gervase Markham [:gerv]
darin.moz: approval‑branch‑1.8.1+
jaymoz: approval1.8.0.4+
Details | Diff | Review

Description Gervase Markham [:gerv] 2006-03-20 06:17:23 PST
The .cat TLD should be added to the IDN whitelist.
Registry: http://www.domini.cat
Policy: http://www.domini.cat/normativa_registre.html 

The allowed characters consist of ten accented forms of Latin letters,
plus U+00B7 CATALAN MIDDLE DOT - ·. There are possibly some spoofing possibilities with this, but they are mitigated by the fact that the registry representative assures me that it is only permissible directly between two "l" characters, which is the only permitted use in Catalan.

So I think it's reasonable to make an exception to our general "no punctuation" rule, for .cat only, for the time being. However, if future IETF/ICANN recommendations relating to characters allowed in IDN change the situation, then of course we reserve the right to re-evaluate all entries in the whitelist.

So, on this basis, I am approving .cat for inclusion.

Gerv
Comment 1 Gervase Markham [:gerv] 2006-03-20 06:45:14 PST
Created attachment 215657 [details] [diff] [review]
Patch v.1

Here's the patch, with a request for the relevant approvals. By precedent (see e.g. bug 322996), no code review or trunk baking is required because this patch is political rather than technical.

Gerv
Comment 2 Darin Fisher 2006-03-22 19:22:51 PST
Comment on attachment 215657 [details] [diff] [review]
Patch v.1

a=darin for the MOZILLA_1_8_BRANCH
Comment 3 Jay Patel [:jay] 2006-04-05 12:23:03 PDT
Comment on attachment 215657 [details] [diff] [review]
Patch v.1

Please check in promptly on the 1.8.0 branch.  Thanks!
Comment 4 Daniel Veditz [:dveditz] 2006-04-28 11:58:47 PDT
Reassigning to myself so i don't forget to check this in for Gerv.
Comment 5 Gervase Markham [:gerv] 2006-04-28 13:21:44 PDT
Checked in on all branches earlier this afternoon. Sorry I forgot to update the bug.

Gerv

Note You need to log in before you can comment on or make changes to this bug.