List items in Main Window are displayed screwy if Subject contains newline character

RESOLVED DUPLICATE of bug 271312

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 271312
12 years ago
11 years ago

People

(Reporter: Thomas Keller, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Thunderbird Version 1.5 (20051201)


I recently received some emails with a broken Subject line via a mailing list (screenshot is attached). Apparently this broken subject line "scrambles" the message list view in Thunderbird. The subject line is as follows ("response times" is broken over the next line):


Subject: Re: [Monotone-devel] [PATCH] pre-cache database file to improve
	response time
From: =?ISO-8859-1?Q?Beno=EEt?= Dejean [...]

If the single message line is activated, a small "NL" is displayed in place where the newline is put in, but as soon as another window forces a repaint of the message window, the contents are scrambled again.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

12 years ago
Created attachment 215699 [details]
Scrambled list view (this is not photoshop'd or Gimp'd or anything!)
(Reporter)

Comment 2

12 years ago
Created attachment 215700 [details]
Email activated, small "NL" sign pops up

Comment 3

12 years ago
Duplicate of bug 240425, maybe related to bug 271312 comment 1 and Suite Bug 240924 comment 6 (the small "NL")?
(Reporter)

Comment 4

12 years ago
Well, I suppose since any of the mentioned bugs are several months, if not years old and nothing has happened until now (TB 1.5), this should simply somehow be fixed soon? Whether or not it is standard to remove \t \n aso. from a subject, they could still be displayed in the main msg window, but they should really be removed before these subject lines are displayed in the list view. I just thought today somebody was able to hack my Thunderbird with an unknown mail worm.

IMHO there is no real reason why a subject line should contain any of these weird characters... something like

s/[\t\n\r]+/ /

on the subject line replacing any multiple tabstops, newlines or carriage returns with a single space char would probably be enough, wouldn't it?

Comment 5

11 years ago
(In reply to comment #4)
> IMHO there is no real reason why a subject line should contain any of these
> weird characters... something like
> 
> s/[\t\n\r]+/ /
> 
> on the subject line replacing any multiple tabstops, newlines or carriage
> returns with a single space char would probably be enough, wouldn't it?

I suppose it would.  We await your patch.

*** This bug has been marked as a duplicate of 271312 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.