Open Web Location > New Navigator or New Composer Window broken

VERIFIED FIXED

Status

P3
blocker
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: gerv, Assigned: law)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win95; U)
BuildID:    20000323

Reproducible: Always
Steps to Reproduce:
1. File | Open Web Location
2. Change the drop-down list box to New Navigator Window
3. Enter a URL, and ask it to open it

Actual Results:  You get a popup error:
"www.all,dialog%3dno.com could not be found. Please check the name and try 
again."

Expected Results:  New Navigator window opens with URL specified.

This broke between 20000314 and 20000317 - at the same time that the way of 
selecting what sort of "Open" it should be changed from radio buttons to a list 
box. I have reports of this on both Mac and Linux.
not an xpmenu bug
Assignee: pinkerton → law
Component: XP Toolkit/Widgets: Menus → XPApps
Severity: major → critical
Hardware: PC → All
Summary: File | Open Web Location | New Navigator Window broken → Open Web Location > New Navigator Window broken
i also see this when trying to open a link in a new composer window --at least
on linux and mac.
Severity: critical → blocker
Summary: Open Web Location > New Navigator Window broken → Open Web Location > New Navigator or New Composer Window broken
to be more specific:

when i try to bring up a new navigator or composer window via Open Web Location,
a new window (not popup dialog) appears, lacking toolbars, at
search.netscape.com, with the title, "Search results -- all dialog=no."

tested using optimized, commercial bits from the tip [2000.03.24.10].
URL: Noneany
(Assignee)

Comment 4

19 years ago
It is definitely broken on the trunk.  Recent change to UI was accompanied by 
some bogus JS (remove the "_blank" args to delayedOpenWindow if you want to fix 
it for yourself).  I'll check in the fix after my 3:00 meeting.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

19 years ago
*** Bug 33016 has been marked as a duplicate of this bug. ***
Keywords: dogfood, regression

Comment 6

19 years ago
Ben broke this in openLocation.js rev 1.15. cc:ing him so he'll at least know 
what he did. He Ben, you tested this before inserting an extra parameter and 
checking it in, right?
(Assignee)

Comment 7

19 years ago
Fix has been submitteded for review.  The reviewer has scheduled the review for
Sat Apr 01, 2000 at 2:15 PM PDT.  Anybody interested in reviewing should attend.
 If you can't make it, please call me and we'll reschedule.  You should see the
fix on Thu Apr 06, 2000, at the latest.

Hah hah.  Just kidding.  I checked it in just a few minutes ago.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
verified as fixed:

linux, opt comm: 2000.03.27.11
macOS, opt comm: 2000.03.27.10
winNT, opt comm: 2000.03.27.09
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.